Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Great performancer booster

Recommended Posts

I have my Pentium 4 1.6ghz, gf3 ti 200, 256mb sd ram running doom 3 at a damn near constant 20fps(exception of firing which is explained at the bottom of the page, and no being attacked doesnt bother me nor do the imps/pinkys complex animations like leaping, one other exception are the particle heavy situations like when the imp spawns in where the table is in e3_2, strangley not that wierd laser thing).
here's how i did it: open up doom3.config with note pad and change the follwing values:
seta r_useGL2 from 1 to 0 (as if im not mistaken gl2.0 is not even in use yet correct me if im wrong, as this is the biggest framerate booster.),
seta r_useStandardGL from 0 to 1 (well it has to use some form of gl and imo it doesnt change the gfx much at all really.),
seta image_anisotropy from 8(!!!!) to whatever image filtering level your gfx card can handle (probably 4, for me its 2),
a few lines before the anisotropy there are a bunch of lines for image compression set them all to 1,
r_mergeShadows set from 1 to 0,
seta r_ext_compress_textures from 0 to 1,
seta r_colorbits 32 to 16
seta r_fullscreen 0 to 1 (running windowed reduces performance)
seta r_shadows 1 to 0
s_reverbPercentage 20 to 0
seta s_roomAcoustics from 1 to 0 (another major performance booster)
(it's important to set those two because if im not mistaken it will still process the reverb info even with sound disabled, dunno why)
seta com_maxfps from 200 to 999
These two i did not mess with and i am sure they will kill doom3's look:seta r_depthbits 32 to 16
seta r_stencilbits 32 to 16
a few more you can change with big hits to gfx are the likes of image depth and some others on that line (which is comprised of most of the higher end fx)

the only thing i am having real trouble as far as steep and sudden performance hits are weapons firing (monsters attacking no longer slow me)I know it has to do with the muzzle flash and smoke fx. if anyone knows how to disable muzzle flashes plz pm me, thanks.

sorry for the parameters being out of order i was copying and pasting as i figured out what helped and what didnt, you will have to hunt for them, again sorry
and no im not all that tech savvy ive just been tweaking id engine games configs for a long time to keep the games running smooth on my always sub par gfx card(s) so don't bash me on my lack of knowledge on things such as gl2.0 please

Share this post

Link to post

Interestingly, I get the greatest increase in performance out of disabling shadows (some scenes go from 10 to 20 fps). That's great because getting rid of the shadows is really a lesser distraction than disabling bumpmapping.

Share this post

Link to post

Actually, you should set the aniso value to zero. It's software anisotropic filtering, relies on your CPU. Set it to zero and turn on your graphics card's aniso, it'll look slightly worse and run much better.

Share this post

Link to post

Turning off the hud gives 2 FPS extra

com_drawhud 0

Check these Skip commands also, some help increase the speed:

r_skipBump = 1 (not much difference in FPS tho, and looks ugly)
r_skipGuiShaders = 0 (haven't touched it)

r_skipSubviews = 0 (?)
r_skipUpdates = 0 (?)
r_skipFrontEnd = 0 (?)

r_skipDeforms = 0 (?)
r_skipFogLights = 1 (helps quite a lot)
r_skipBlendLights = 1
r_skipAmbient = 1 (removes blood, steam etc)
r_skipTranslucent = 1 (obvious)
r_skipRenderContext = 0 (why should you?)
r_skipRender = 0
r_skipBackEnd = 0
r_skipCopyTexture = 0
r_skipDynamicTextures = 1 (dunno about this one, didn't see any changes)

I'll hope to find some more.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this