Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SlayerOGames666

PROBLEM: WolfenDOOM: Blade Of Agony v2.0 doesn't work on newest version of GZDoom?

Recommended Posts

On a fresh install of WolfenDOOM BOA, this error message pops up every time i want to play it:
Script error, "boa_c2.pk3:scripts/menus/playermenunamebox.txt" line 13:
Unknown identifier 'MAXPLAYERNAME'
Script error, "boa_c2.pk3:scripts/actors/playerfollowers.txt" line 321:
Type mismatch in function argument
Could anyone please tell me how to fix it? I'll try fixing it today, but i'll come back later to see what yall are saying.

Share this post


Link to post

IIRC it's because GZDoom has updated but the mod itself has not, and it's changed how some internal stuff works. I think you'd need to download an older version of GZDoom.

 

Though perhaps the man himself would have a better answer than I would. @Tormentor667?

Share this post


Link to post
28 minutes ago, Dark Pulse said:

IIRC it's because GZDoom has updated but the mod itself has not, and it's changed how some internal stuff works. I think you'd need to download an older version of GZDoom.

 

Though perhaps the man himself would have a better answer than I would. @Tormentor667?

I will try and update that code to the newest version of GZDoom today. Hopefully Tormentor can help us out here.

Share this post


Link to post

Alright, so @Tormentor667, in boa_c2.pk3:scripts/menus/playermenunamebox.txt, there doesn't seem to be a MAXPLAYERNAME defined.
and I'm not sure about the second error, or known as boa_c2.pk3:scripts/actors/playerfollowers.txt, line 321. Can you please diagnose, and let me know if i am wrong of this or not?

Share this post


Link to post
17 hours ago, Dark Pulse said:

IIRC it's because GZDoom has updated but the mod itself has not, and it's changed how some internal stuff works. I think you'd need to download an older version of GZDoom.

 

Though perhaps the man himself would have a better answer than I would. @Tormentor667?

 

That's most propably the reason. You can play the standalone from the ModDB instead, it includes the right version of GZDoom to be played with.

Share this post


Link to post
6 hours ago, Tormentor667 said:

 

That's most propably the reason. You can play the standalone from the ModDB instead, it includes the right version of GZDoom to be played with.

OK. Hopefully Chapter 3 (full TC) will be compatible on GZDoom 4.3.3 above.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×