Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ludicrous_peridot

GUS and Timidity++ settings in GZdoom 4.4.2

Recommended Posts

Would it be possible for anyone who has subj working with set of patches share their config for gzdoom and timidity via PM? I am lost as to what I'm doing wrong but have no luck at all with that. The patches and timidity config work when timidity is used as MIDI synthesizer via twsyng, so I can use them from GZdoom via a MIDI device. I would like to listen to native GZdoom GUS/Timidity sound, and that's where I fail.

Share this post


Link to post

Oh, I was able to figure it out after all - and holy molly, was I surprised. The problem was not in configs for timidity, nor in gzdoom settings pointing to those. But, I had to remove all soundfont directories from search, as otherwise GZdoom did me a favor of extracting patches from the sf2 files it encountered. Just leaving only fm bank directories in directory search paths, and setting fluid_patchset to the sf2 I was interested in for Fluidsynth did the trick. I take it GZdoom would apply found soundfonts to every SWSYNTH type MIDI device.

 

Took note of DeltaTouch for Android that has working configs for GUS, Timidity++ and Fluidsynth in its audiopack out of the box.

Share this post


Link to post

I have no idea what you did but such a thing should not happen. I routinely use EAWPats and all the .SF2s in my search directory never bother it. What does your config look like? Be aware that Timidity++ can do weird things if it finds files in the path it gets pointed to that you never have on your radar.

 

With GUS patch sets you may be better off zipping the entire directory's contents and putting that archive in the soundfonts folder. That should greatly reduce the chance of unwanted interferencre.

 

Share this post


Link to post

Understood Graf.

I was aiming to have the patches sit in one place in the system for both my synthesizers and GZDoom to use and as I don't mind tweaking cfgs in the patches sets, I would rather not zip them.

Will PM you the config I have and have attached my directories structure. 

As for what I did to make GUS and Timidity sound right - I simply removed the soundfonts dir that came in GZDoom zip. Some of the config additions were made afterwards. This same sound issue I had on another PC with the same layout. The other one was running Windows 8.1.

 

Spoiler

doom_gus.PNG

 

EDIT:

I think I am starting to see what I was doing wrong: I had searchpaths for soundfonts on in the ini (and sf2 files actually found in the dirs), AND was setting midi_config, gus_patchdir and timidity_config to explicit path to the configuration files, patches directory. Re-reading @Graf Zahl's post I think these two options are unlikely designed to be mixed: i.e. either you add the dirs (conveniently at the top of ini file) and use menus to select the patches sets, OR you set the more obscure cvars to explicit paths. I honestly haven't tried pointing GZDoom to my patches using searchpaths.

Edited by ludicrous_peridot

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×