Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
TheEvilGrin

My DECORATE definition doesn't work for some reason

Question

Hello everyone,

I'm making a custom lamp in DECORATE for my wad, but when I launch the game, this message pops up :

Script error, "marsholeresources.wad:DECORATE", line 1 :

Error parsing defs. Unknown tag : actor.

 

If I understand (I guess I don't then), the problem comes from the word "actor", and iirc, it's how you define an actor, isn't it ? Here's the full code :

 

Actor BlueTechLamp 1001
{

Radius 16
height 32
+SOLID
 

States {
Spawn :
BTLP ABCD 10 Bright

}
}

 That's really weird (there's also a function that doesn't work, A_AttachLightDef, but apparently you have to do that in GLDEFS now).

Anyone knows what's happening ?

Thanks in advance !

Share this post


Link to post

5 answers to this question

Recommended Posts

  • 0

I see one issue at least with your GLDEFS. You should not be attaching the light to an object within a light definition. Move that last bracket so that it's after Dontlightself instead.

Share this post


Link to post
  • 1

I copied your code (and replaced the sprite name to TRED), and it didn't give me an error. Is there anything else at all in your DECORATE or is that the entire thing?

Share this post


Link to post
  • 0

Are you by chance using an ancient version that doesn't support that DECORATE format?

Share this post


Link to post
  • 0

There is indeed another actor definition right after, but it's basically the same and causes the same bug. There's also a GLDEFS lump, though, which calls for this one, and that might be the issue. I removed the "#include DECORATE" from the GLDEFS, and now I got a "Unknown tag: object" error in the GLDEFS. Really weird, given that even if I use an example from the ZDoom wiki it still refuses to work. Here's the GLDEFS code :

pulseLight TECH
{
color 0.1 0.0 1.0
size 16
secondarysize 64
interval 2
Dontlightself 1

object BlueTechLamp
{
 frame BTLP {light TECH}


}

}

Share this post


Link to post
  • 0
36 minutes ago, Nevander said:

I see one issue at least with your GLDEFS. You should not be attaching the light to an object within a light definition. Move that last bracket so that it's after Dontlightself instead.

Yep, that was it. Stupid me.

Thanks a lot !

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×