Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TheVanessii

[Crispy Doom] How do I use custom .sf2 Soundfont?

Recommended Posts

Can't really find a good tutorial anywhere, and I saw that fabian replied to a topic about it, however, I'm still confused.
He said
 

Quote

You don't need timidity anymore, SDL2_Mixer is built with fluidsynth support for rendering soundfonts. You just need to tell SDL2_Mixer which soundfont to use by setting the SDL_SOUNDFONTS environment variable, e.g. "export SDL_SOUNDFONTS=/path/to/soundfont".

but I use ZDL and tried doing this, and it didn't work. I'm trying to use fatboy .sf2 with crispy doom btw. 
Any help would be appreciated! Thanks 

Share this post


Link to post

Following this because I just asked this question in the Crispy Doom thread as well:

Quote

I'm on Debian GNU/Linux 10 with Crispy Doom 5.10 (compiled from source), and I can't seem to figure out how to use a custom soundfont. I've so far tried:

  • Using a timidity.cfg file with "soundfont /path/to/soundfont" (no music)
  • Adding "soundfont /path/to/soundfont" to the existing timidity.cfg file, and using that (music had missing instruments and was from the wrong soundfont)
  • Setting the SDL_SOUNDFONTS environment variable to the full path to my soundfont, no Timidity configuration file (no effect, still uses default soundfont)

It's a shame, because this is the one of the last things that keeps me using PrBoom+ over Crispy Doom.

Share this post


Link to post
8 minutes ago, Dimon12321 said:

Here is a silly instruction: 

https://ibb.co/5FP0wyf

 

Point 5 there means that timidity file should have the same file name as the sf2 file in the game folder. 

Not sure if you sent the right image there - I see two steps in the image.

 

Anyway, it seems like naming the .cfg the same as .sf2 has an effect, but there are missing instruments.

Share this post


Link to post
19 minutes ago, Dimon12321 said:

Here is a silly instruction: 

https://ibb.co/5FP0wyf

 

Point 5 there means that timidity file should have the same file name as the sf2 file in the game folder. 

This did not help, and it didn't work

Share this post


Link to post

Bump since we're still looking for an answer

20 minutes ago, Dimon12321 said:

Here is a silly instruction: 

https://ibb.co/5FP0wyf

 

Point 5 there means that timidity file should have the same file name as the sf2 file in the game folder. 

Also, I don't have a timidity file, and idk how to set up a sf2 file with timidity. And also, fabian said 
downloading Timidity isn't necessary, so really wanna find out how I can do it without downloading timidity.

Share this post


Link to post

The simplest way I can think of is to use VirtualMIDISynth, though it does change the way your whole system's MIDI output works until you uninstall it as far as I know. Still, I use it for everything, even to simply map what output device to use for MIDI. If you want to go back to using Microsoft's default synth with VMS still installed, and VMS doesn't use what you selected for some reason, you can also install MIDIMapper by the same company, and they will both work for selecting your preferred MIDI output. I have MIDIMapper installed and control it with VMS, but I'd also refrain from installing it unless VMS doesn't switch outputs properly.

 

To use it with Crispy, you'll need to install VirtualMIDISynth, load the soundfont you want, and set the Default MIDI Out Device to VirtualMIDISynth #1 in the MIDI Mapper panel. Then in Crispy's config settings, set the music to MIDI/MP3/OGG/FLAC and leave the Timidity configuration file blank.

 

I highly recommend using VMS anyway because it gives you way more control for MIDI in every source port, and even DOSBox (requires a few extra steps).

Share this post


Link to post
29 minutes ago, Lippeth said:

The simplest way I can think of is to use VirtualMIDISynth, though it does change the way your whole system's MIDI output works until you uninstall it as far as I know. Still, I use it for everything, even to simply map what output device to use for MIDI. If you want to go back to using Microsoft's default synth with VMS still installed, and VMS doesn't use what you selected for some reason, you can also install MIDIMapper by the same company, and they will both work for selecting your preferred MIDI output. I have MIDIMapper installed and control it with VMS, but I'd also refrain from installing it unless VMS doesn't switch outputs properly.

 

To use it with Crispy, you'll need to install VirtualMIDISynth, load the soundfont you want, and set the Default MIDI Out Device to VirtualMIDISynth #1 in the MIDI Mapper panel. Then in Crispy's config settings, set the music to MIDI/MP3/OGG/FLAC and leave the Timidity configuration file blank.

 

I highly recommend using VMS anyway because it gives you way more control for MIDI in every source port, and even DOSBox (requires a few extra steps).

image.png.4b5853d50118676226a3cdc785ecce30.pngimage.png.057a8e0d65bf7e67ec3843b086090747.pngimage.png.6eac6f88cb75ac839bff2e28d0872662.png
It still doesn't work
(I know it's not an issue with the program, as it works with gzdoom. Cannot make anymore posts as I've reached the maximum allowed for today. I don't think crispy doom gives the option to use windows' default midi device, probably why it didn't work.
I'm still looking for help)

Edited by TheVanessii

Share this post


Link to post

You may need to restart your computer. I know that when installing or updating, it gives you a list of programs that need to be exited in order to properly install. If that still doesn't work then that was my absolute best attempt at getting you set up, and I have no other suggestions other than waiting for someone with the best solution.

Share this post


Link to post
8 minutes ago, forgettablepyromaniac said:

I just use Timidity++ and use the .cfg to point it towards whatever .sf2 I want to use instead of using FluidSynth.

What are the contents of your .cfg file?

Share this post


Link to post
4 minutes ago, forgettablepyromaniac said:

See image I just included.

Still not working :(

 

I didn't have quotes around the file path, but adding them had no effect.

 

Might work for OP on Windows, though.

Share this post


Link to post
49 minutes ago, TheVanessii said:

image.png.4b5853d50118676226a3cdc785ecce30.pngimage.png.057a8e0d65bf7e67ec3843b086090747.pngimage.png.6eac6f88cb75ac839bff2e28d0872662.png
It still doesn't work
(I know it's not an issue with the program, as it works with gzdoom. Cannot make anymore posts as I've reached the maximum allowed for today. I don't think crispy doom gives the option to use windows' default midi device, probably why it didn't work.
I'm still looking for help)

 

This is exactly how I have Crispy set up to use VMS and it works perfectly fine, FWIW.

Share this post


Link to post
3 minutes ago, northivanastan said:

Still not working :(

 

I didn't have quotes around the file path, but adding them had no effect.

 

Might work for OP on Windows, though.

If it helps, within the below Spoiler is my Zandronum .cfg when it comes to Timidity:
 

Spoiler

timidity_frequency=22050
timidity_pipe=90
timidity_mastervolume=1
timidity_byteswap=false
timidity_8bit=false
timidity_stereo=true
timidity_reverb=0
timidity_chorus=0
timidity_extargs=
timidity_exe=C:\Users\[NAME]\Desktop\Games\Doom\Source Ports\Zandronum\timidity4zdoom2\timidity.exe


And then you need to set the Midi Player settings to play Timidity specifically:
 

Spoiler

lol.png.5744469eac72ea994c0f1fd3759bcfff.png

Furthermore, some versions of Timidity don't work with certain versions of G/ZDoom/Zandronum

So if you need me to I can copy my version into a .zip file.

Share this post


Link to post
Just now, forgettablepyromaniac said:

If it helps, within the below Spoiler is my Zandronum .cfg when it comes to Timidity:
 

  Reveal hidden contents

timidity_frequency=22050
timidity_pipe=90
timidity_mastervolume=1
timidity_byteswap=false
timidity_8bit=false
timidity_stereo=true
timidity_reverb=0
timidity_chorus=0
timidity_extargs=
timidity_exe=C:\Users\[NAME]\Desktop\Games\Doom\Source Ports\Zandronum\timidity4zdoom2\timidity.exe


And then you need to set the Midi Player settings to play Timidity specifically:
 

  Reveal hidden contents

lol.png.5744469eac72ea994c0f1fd3759bcfff.png

Furthermore, some versions of Timidity don't work with certain versions of G/ZDoom/Zandronum

So if you need me to I can copy my version into a .zip file.

I never used any of the ZDoom ports, and this works perfectly on PrBoom+ and Doomsday. They use Fluidsynth out of the box and there's a very clear place where I can set a soundfont. It's Crispy Doom that's the issue here.

Share this post


Link to post
3 minutes ago, northivanastan said:

I never used any of the ZDoom ports, and this works perfectly on PrBoom+ and Doomsday. They use Fluidsynth out of the box and there's a very clear place where I can set a soundfont. It's Crispy Doom that's the issue here.

Might require a bit of confuzzling then, but I know it's plausable.

Share this post


Link to post
On 2/18/2021 at 9:48 AM, Lippeth said:

The simplest way I can think of is to use VirtualMIDISynth, though it does change the way your whole system's MIDI output works until you uninstall it as far as I know. Still, I use it for everything, even to simply map what output device to use for MIDI. If you want to go back to using Microsoft's default synth with VMS still installed, and VMS doesn't use what you selected for some reason

When it comes to setting the MIDI mapper in VMS, I find I have to do each change individually. So I'll have to select my "Default MIDI out device", click apply and ok, then come back to the tab once again to change my "Windows Media Player default device". Setting them both at the same time seems to (oddly) not work. Only after a bit of fiddling around did I finally figure this out!

Share this post


Link to post

That is strange, but great to know! VMS does have some weird quirks from time to time, but it's a godsend considering the amount of configurations and devices I like to use. Like I always know when a new update is available because it will outright refuse to play MIDI.

Share this post


Link to post
On 2/20/2021 at 12:19 PM, Lippeth said:

That is strange, but great to know! VMS does have some weird quirks from time to time, but it's a godsend considering the amount of configurations and devices I like to use. Like I always know when a new update is available because it will outright refuse to play MIDI.

Btw! VirtualMIDISynth worked for me, I found out the issue. It was the line I left on my command line in ZDL, telling it to use a certain config for the source port, but 

somehow when I used the -config command along with it, it didn't use the sound settings I set from the setup .exe. Thank you once again btw, everything works smoothly

Share this post


Link to post

Excellent! Glad to know it's working out. Doom with no music is like a car with no gas. Enjoy the soundfonts!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×