Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
northivanastan

[RESOLVED] Disabling freelook in GZDoom

Recommended Posts

I'm trying out GZDoom for the first time (on Debian GNU/Linux 10), and I'm having trouble getting the settings right. I want to disable freelook and vertical mouse movement, so as to have horizontal look only. Problem is, when I go into Gameplay Settings and disallow freelook, the setting is not saved. Apparently this is because gameplay settings are supposed to be dependent on the game/WAD and not stored in the INI file.

 

The only way I could find to permanently disable freelook is:

  1. enable permanent mouselook in Mouse Settings
  2. disable freelook in Gameplay Settings
  3. note the value of the dmflags variable at the top of the screen
  4. Add "set dmflags <variable from step 2>" to ~/.config/gzdoom/autoexec.cfg

 

I feel like there has to be a better way to do this. As it is, if I ever want to change my gameplay settings, I have to go through the same process of copying the dmflags variable to autoexec.cfg. Is this really the best way? Am I the only GZDoom user who wants my controls set up like this?

Edited by northivanastan : mark resolved

Share this post


Link to post

I wonder if the setting not getting saved isn't a bug.

 

Not sure how it works under Linux, but on Windows simply turning the freelook toggle off in mouse setting and leaving the last two sliders on 0 works just fine to simulate novert and disable vertical mouse movement.

Share this post


Link to post
2 minutes ago, seed said:

I wonder if the setting not getting saved isn't a bug.

 

Not sure how it works under Linux, but on Windows simply turning the freelook toggle off in mouse setting and leaving the last two sliders on 0 works just fine to simulate novert and disable vertical mouse movement. 

I didn't see those sliders. Setting vertical speed to 0 works, so thanks! PrBoom+ had to use a similar workaround, so I should have known.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×