Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
DoomSlayer69

GZDoom Weird HUD

Recommended Posts

I have a question regarding my HUD in GZDoom, the HUD background art looks zoomed in and blurry, which seems different to other source ports. If possible, can you guys tell me how to fix the GZDoom HUD? I am using the latest version. Texture filtering just got turned off, but it didn't fix the HUD background art being ugly.

 

What my HUD looks like:

BadHud.PNG.f6c97fa4da4effc91c0fdfacb40d298f.PNG

 

What I want it to look like:

Screenshot_Doom_20100529_173239.png.11f569fe566bf3882843e545196827d0.png

Share this post


Link to post

What's your resolution? It may be scaled up oddly.

Share this post


Link to post

If you're using simple options, Options -> Display options -> Texture Filter Mode -> set to one of None values.

With expanded options, it's Options -> Display options -> Texture options -> Texture Filter Mode.

 

Also play with Scaling and HUD options.

Share this post


Link to post

Disable texture filtering or set it to None (Linear/Bilinear/Trilinear), and enable "HUD preserves aspect ratio".

Share this post


Link to post
1 hour ago, seed said:

Disable texture filtering or set it to None (Linear/Bilinear/Trilinear), and enable "HUD preserves aspect ratio".

Didn't work, and I've already turned off texture filtering before posting.

 

Share this post


Link to post

Needs more info.

 

What "didn't work"?

Share this post


Link to post

Go to HUD -----> scaling options and scale the hud to whatever appearance you like the most

 

Edit: If you want a classic style looking gzdoom watch this tutorial, Dwars uses an older GZDoom but it should be the same

Edit 2: Watch from 4:16, there he explains how to change the hud

 

Edited by Lol 6

Share this post


Link to post
1 hour ago, DoomSlayer69 said:

Didn't work, and I've already turned off texture filtering before posting.

Do you have an .ini file inside your GZDoom folder?
It basically saves your GZDoom settings and you can also configure settings inside it.

Share this post


Link to post
On 2/28/2021 at 7:38 AM, DoomSlayer69 said:

I have a question regarding my HUD in GZDoom, the HUD background art looks zoomed in and blurry, which seems different to other source ports. If possible, can you guys tell me how to fix the GZDoom HUD? I am using the latest version. Texture filtering just got turned off, but it didn't fix the HUD background art being ugly.

 

What my HUD looks like:

BadHud.PNG.f6c97fa4da4effc91c0fdfacb40d298f.PNG

 

What I want it to look like:

Screenshot_Doom_20100529_173239.png.11f569fe566bf3882843e545196827d0.png

Go to HUD Settings, and enable "HUD preserves aspect ratio".

that should make the HUD look how you want it to.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×