Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
evanisdead

[SOLVED] Boom mapping format issues

Recommended Posts

Posted (edited)

After testing MAP03 of Going Down with Eternity, Zandronum, and DSDA Doom it came to my attention that one of the linedefs using a generalized action is broken on Eternity and none of the other boom-compatible ports. The action that cannot be performed is 24600. I have very little knowledge regarding Boom-mapping so this is as much info as I can provide after doing a little bit of debugging.

 

EDIT: Upon further debugging, I realized it's not a bug in generalized actions, but rather any action containing "lower floor to next highest floor". Tested with a predefined action, same result occurs. Some floors appear to be moving up instead of down, like in the aforementioned map. Changing the action to "lower floor to next adjacent floor" fixed the map, but if any other wads used the "lower to next highest floor" action, they would likely also break on Eternity. I hope this information proves useful!

Edited by evanisdead

Share this post


Link to post
Posted (edited)

Looking into it. Thanks for the report. Which of the two 24600 lines is it that's having an issue on MAP03?

 

Also wait, "lower floor to next highest floor"? But 24600 is the highest adjacent floor, rather than the next highest adjacent floor.

Share this post


Link to post

OK I just tested it in MAP03 of Going Down on a current devbuild and can't reproduce it. It's working just as it does in GZDoom. What version of Eternity are you using?

 

Share this post


Link to post
On 5/25/2021 at 7:47 AM, evanisdead said:

EDIT: Upon further debugging, I realized it's not a bug in generalized actions, but rather any action containing "lower floor to next highest floor". Tested with a predefined action, same result occurs. Some floors appear to be moving up instead of down, like in the aforementioned map. Changing the action to "lower floor to next adjacent floor" fixed the map, but if any other wads used the "lower to next highest floor" action, they would likely also break on Eternity. I hope this information proves useful!

I've definitely not experienced this, using Eternity as my primary port for playing and mapping. I wonder if you have an odd compatflag set that's causing some unexpected behavior...

Share this post


Link to post
Posted (edited)
43 minutes ago, Altazimuth said:

OK I just tested it in MAP03 of Going Down on a current devbuild and can't reproduce it. It's working just as it does in GZDoom. What version of Eternity are you using?

 

Was using v4.01.00. Just updated to v4.02.00 and the bug is mysteriously fixed. Nothing in the changelog that would explain what happened...

I will change my settings back to the way they were in my 4.01.00 version and see if the bug re-occurs. If not, I'll consider this thread solved.

EDIT: Very interesting, the bug re-occurred after I changed my settings. Should I upload my game and system config files for observation? Maybe someone can pinpoint the problem. Also, I noticed that alt+enter does not switch to windowed mode with my settings either. It did work when I downloaded a fresh version, but after a bit of messing around with the settings, it broke.

Edited by evanisdead

Share this post


Link to post
Posted (edited)

It either was a bug, or maybe you have the floor movement and/or linedef trigger model settings changed? They're the ones from the compatibility menu with "use exactly Doom's floor motion behavior" or "use exactly Doom's linedef trigger model".

Share this post


Link to post
3 minutes ago, printz said:

It either was a bug, or maybe you have the floor movement and/or linedef trigger model settings changed? They're the ones from the compatibility menu with "use exactly Doom's floor motion behavior" or "use exactly Doom's linedef trigger model".

That was it, thank you! I set everything to vanilla just to be safe because I want the vanilla demos to work correctly, being too unfamiliar with the changes Boom introduced to the engine. I changed both floor movement and linedef trigger settings to false. Glad it's not a bug.

 

The thread is solved now!

Share this post


Link to post

If I remember right, vanilla demos should play back correctly regardless of your compatibility settings. You can also start with the -vanilla command line parameter to temporarily enforce vanilla compat mode.

Share this post


Link to post
39 minutes ago, esselfortium said:

If I remember right, vanilla demos should play back correctly regardless of your compatibility settings. You can also start with the -vanilla command line parameter to temporarily enforce vanilla compat mode.

Thank you :)

Share this post


Link to post
On 5/26/2021 at 10:02 PM, esselfortium said:

If I remember right, vanilla demos should play back correctly regardless of your compatibility settings. You can also start with the -vanilla command line parameter to temporarily enforce vanilla compat mode.

Going Down is for Boom, however. Not vanilla, not MBF, but Boom. We don't have something like a "-boom" command-line yet.

Share this post


Link to post
Posted (edited)
On 5/26/2021 at 9:27 PM, evanisdead said:

That was it, thank you! I set everything to vanilla just to be safe because I want the vanilla demos to work correctly, being too unfamiliar with the changes Boom introduced to the engine. I changed both floor movement and linedef trigger settings to false. Glad it's not a bug.

 

The thread is solved now!

Well, I would really like to enforce certain compatibility settings for wads, so future players don't have the same problem. Can you tell which setting did you change that affected the gameplay? I tried setting all of "Use exactly DOOM's..." settings to YES and the floors still lowered as expected.

 

Do I need monsters to exist in the level? Vanilla Doom has the problem of nearby stuck monsters also affecting the movement of sectors otherwise not blocked by them (Boom fixed that by adding the comp_floors gameplay setting). If you have comp_floors set to yes, such sectors would remain jammed.

Share this post


Link to post
On 5/29/2021 at 12:49 PM, printz said:

Well, I would really like to enforce certain compatibility settings for wads, so future players don't have the same problem. Can you tell which setting did you change that affected the gameplay? I tried setting all of "Use exactly DOOM's..." settings to YES and the floors still lowered as expected.

 

Do I need monsters to exist in the level? Vanilla Doom has the problem of nearby stuck monsters also affecting the movement of sectors otherwise not blocked by them (Boom fixed that by adding the comp_floors gameplay setting). If you have comp_floors set to yes, such sectors would remain jammed.

I toggled both floor and linedef behavior to true, so it's one of those. But since it also affected a vanilla (maybe?) linedef, I have a suspicion that it might be a bug with the sector setup on that particular map. I'll have to do some tests in doom builder to see what exactly causes the flat to malfunction. Will get back to your on this once I get some results.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×