Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Gothic

Auto Aligning textures while mapping for Eternity in UDB

Question

For some reason, the auto align functions don't work on 3D mode while mapping for Eternity UDMF, unless I select the textures, but that's just tedious. I checked and I have those functions binded, is this a bug, or there is something else I need to do while mapping for Eternity?

Share this post


Link to post

10 answers to this question

Recommended Posts

  • 0

I'm guessing this is an oversight in UDB relating to the fact that ZDoom UDMF has separate upper/mid/lower texture alignments, and Eternity's alignments are just per-line like in vanilla. I wonder if that's something that can be toggled in the Eternity UDMF cfg file.

Share this post


Link to post
  • 0

Works fine for me.

 

8 hours ago, esselfortium said:

I'm guessing this is an oversight in UDB relating to the fact that ZDoom UDMF has separate upper/mid/lower texture alignments, and Eternity's alignments are just per-line like in vanilla. I wonder if that's something that can be toggled in the Eternity UDMF cfg file.

 

There is an option for that, it's called "localsidedeftextureoffsets". It's not set in the EE config, but defaults to "false". You can also see that in the linedef editing dialog. The input boxes for upper/middle/lower offsets are disabled in the sidedef tabs.

Share this post


Link to post
  • 0
Posted (edited)

I should have fixed this for GZDB-BF some years back...

Edited by Altazimuth

Share this post


Link to post
  • 0

Apparently it does work for vanilla Doom textures, but not custom ones

Share this post


Link to post
  • 0
On 6/22/2021 at 7:28 AM, ramon.dexter said:

Gzdb-bf is outdated, use DoomBuilder Ultimate instead.

Yes I know, I'm saying that I fixed this for GZDB-BF years ago.

Share this post


Link to post
  • 0

Anyway, I set it true and now it works. Thanks for the answers.

Share this post


Link to post
  • 0

Bumping this to say, while it aligns textures in the editor, the engine doesn't process them:

 

yubafKy.png

NDNFgUo.png

Plr3OKh.png

vQj1C1N.png

 

Hopefully this gets noticed.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×