Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Rudolph

Softlock in MAP31: Cyberden?

Recommended Posts

Playing through Plutonia, I got to MAP31 and I have found myself unable to get to the Yellow Card: I have defeated all the Cyberdemons and hit all the switches, but for some reason, the final step of the spiral staircase to the Yellow Card is missing.

 

Since the map is fairly short and easy, I have decided to reload my save file and this time, the final step was there.

 

Has this ever happened to anyone else before? If so, is there a way to fix this without reloading, jumping or noclipping?

Share this post


Link to post

It probably isn't - it sounds like the kind of thing that could be caused by performing two actions that raise those stairs too close together, so one of the actions gets ignored. You can do something very similar on Doom2 MAP21 Nirvana, with the four switches on the triangular wooden plinth thing.

Share this post


Link to post
18 hours ago, Rudolph said:

GZDoom 7.1.

4.7.1? Interesting.

Might check it out later if it happens to me. And, it should work without issues because the switches for that stair aren't really close to each other, like in Nirvana...

Share this post


Link to post

It is likely you pressed the switch in the north alcove through the line in front of it, failing to raise the stair. This is a vanilla incompatibility that ZDoom-based ports enable by default. You need to set an option named compat_useblocking / "All special lines can block<use>" or set the game to play in "Doom (strict)" I believe it is called for it to work as intended.


The final step is the north one (sector 23). It is meant to rise when you press the lion switch in the north alcove (line 910). However the stair is not raised by pressing that switch, which actually opens the door to its northeast. The stair is raised by crossing an invisible walk trigger a short distance in front of the switch (line 914).

In its default configuration ZDoom allows use key presses to pass through walk triggers. In Doom, a walk trigger will block a use key press, so you must cross the line to be able to press the switch; in Boom this is possible but must be explicitly enabled by the map author. Many vanilla maps created in the late 1990s rely on the use-blocking behaviour e.g. to force the player to trigger a trap when reaching for a switch he needs to progress. Unfortunately, the ZDoom developers chose to break this behaviour by default -- there was a good reason, but I forget what it was, maybe because of Hexen? But it led to multiple years of infuriating incompatibilities; vanilla/Boom maps that only worked properly in ZDoom, an occurrence common enough that it gained a name.*

 

________
* May I say this is delightfully nostalgic -- it must be over a decade since I last had an opportunity to have a moan on Doomworld about ZDoomisms :). To be fair in more recent times the ZDoom-based ports have been much better about adding compatibility options and maintaining an internal database of maps that need them. This is likely why you don't hear about it so much any more. But for a while in the mid 2000s, the combination "made in Doom Builder" and "tested in ZDoom" meant a map was almost certainly broken even if it used no ZDoom-specific features and should be playable in any source port.

Share this post


Link to post

Well, 4.7.1 has no issues. I played the map as intended on that port, no changes at compatibility. Haven't touched anything at all. 
Map worked fine...

Share this post


Link to post

You have to strafe-jump to the giant throne.

 

Oh wait, you're talking about Plutonia.

Share this post


Link to post

Goddammit.......well, you're not quite wrong though. 4 big muscular mummies are guarding a throne with a key.

Share this post


Link to post
15 hours ago, RjY said:

It is likely you pressed the switch in the north alcove through the line in front of it, failing to raise the stair. This is a vanilla incompatibility that ZDoom-based ports enable by default. You need to set an option named compat_useblocking / "All special lines can block<use>" or set the game to play in "Doom (strict)" I believe it is called for it to work as intended.

Thanks! I have set it to "Doom (Strict)" in 'Compatibility', but I see that the "All special lines can block<use>" was already set to 'Yes'.

Share this post


Link to post
9 hours ago, Rudolph said:

Thanks! I have set it to "Doom (Strict)" in 'Compatibility', but I see that the "All special lines can block<use>" was already set to 'Yes'.

 

Oh. Well in that case I do apologize; I have no other idea what the problem could be :/.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×