Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Argenteo

Crash on Eviternity M27 Heliopolis

Recommended Posts

Eternity engine died while I was on Map 27 Eviternity. Then I opened again, started m27, got the shotgun cross the bridge and crashed again. I restarted the pc and now I cannot open EE. I tried to delete the .app and downloaded again from Official macOsBuild but same results.
Maybe there are some files stored somewhere else? Or what is happening? Have no trouble with EE playing throughout a year and its my main doom source port...
Some mac user with a idea to solve the problem please :( 

Here are some pics. And link to Eviternity.

 

Screen Shot 2022-01-04 at 19.36.20.png

Screen Shot 2022-01-04 at 19.38.40.png

Share this post


Link to post
Posted (edited)

The crash itself is a tough situation to solve because you might be using an older Eternity development build (and if it's just the release it's too old already). We have fixed several crashes since then. Until we get a new release, we recommend the development builds from DRDTeam. Despite their nature, they're generally very stable, and not really worse in quality than the official release. Unfortunately, DRDTeam has failed to produce any up-to-date macOS development builds for awhile, with no explanation. Maybe I should really step up, bite the bullet and provide development builds from my computer…

 

Until then, here's an up-to-date Eternity build for you: EternityEngine-20220105-0a2dff19.zip

 

As for how you can recover from the problem, I'm thinking of the following troubleshooting:

  1. When that dialog appears, try with "Ignore", not "Reopen". The information for reopening may be bad right now, sending it into a loop.
  2. One of the faulty files (which you may need to delete) is this: Library/Preferences/net.mancubus.Eternity-Engine.plist . Open Finder, press Command-Shift-G. This will open the "Go To…" dialog box. Type in the path: ~/Library/Preferences . Scroll down until you get to the net.mancubus.Eternity-Engine.plist file. Back it up somewhere (just by copying it to Desktop, Documents or wherever), and delete it from there. Start Eternity Engine. If it works now, can you please send the backed-up plist file to me if it doesn't contain any confidential information? You can open it with a text editor to check its content. It would be my responsibility to fix so Eternity doesn't crash.
  3. If Eternity still fails to start — but in that case, it would fail when clicking "Start Game", not the very startup — check if there's anything wrong with ~/Library/Application Support/net.mancubus.Eternity-Engine . Use the same Command-Shift-G to go there. You really should only see a user subfolder, for which Eternity would only complain after clicking "Start Game"…

Share this post


Link to post

I looked up for those files and saved them apart. Delete the .app, net.manc...plist. Then I downloaded and try to run the build for me ( Thanks!), but the same eternity engine quit unexpectedly again.


This screen pops when I run the EE inside the .app (maybe it has a clue?). (Image 1)

Then I opened the eternity inside Resources Folder after putting hacx.wad (Image 3).

Twitch n Kill is running and even playing the demo (I didn't know EE could run it with demo compatibility). (Image 2)
Maybe what is failing is the starting interface? 

Here is the plist.

I gotta learn to run it with commands for now. 

Screen Shot 2022-01-05 at 10.39.54.png

Screen Shot 2022-01-05 at 10.47.43.png

Screen Shot 2022-01-05 at 10.48.53.png

net.mancubus.Eternity-Engine.zip

Share this post


Link to post
Posted (edited)

Unfortunately I don't know how to replace the PLIST file with yours because Apple seems to keep the real copy elsewhere and what you see in Preferences is just a shadow, and there's absolutely no help online about it.

 

I can't even open your file. Did you just rename it to .zip without compressing, just to be able to attach it? No problem, I renamed it back to .plist once I figured it out, but even so, I cannot open it! This is unlike my .plist, which is of the same format, so probably it's broken.

 

The launcher is a bit bit-rotten at this moment and I'll have to fix it. I think I'll lose the legacy macOS support in the process, so maybe I'll have to provide a simple binary build for everyone else. In any case, here's the quick solution for you (caution, it deletes the file).

 

  1. Open Terminal
  2. Run this command: defaults delete net.mancubus.Eternity-Engine.plist
  3. Try Eternity Engine now. You will have to input the wads again.

Share this post


Link to post

31032959_ScreenShot2022-01-05at14_56_16.png.646416f89bd337d97eac83fc6b85c22e.png

Seems like it doesn't exist anymore. (Maybe I deleted it at the morning.)
 

Keeps quitting unexpectedly but after changing the permissions in System Preferences, I can use Wad Options to load pwads.

GmAoZnnm.png

 

Warped to M27 Eviternity and those Cyber HellKnights freeze on death and I noticed some weird things going on. Like the pistol shooting slower.


rZxjIMXm.png

 

I guess "loading wad" from options don't read dehacked but on "Autoload" everything is right.

I will miss the launcher but If I can load pwads from the menus I don't mind it.

I know that macOs is a troublesome kid. Thanks for the help! 

 

B6OoBcLl.png

 

Eviternity Eternity Engine groovy!

Share this post


Link to post
2 hours ago, Argenteo said:

I guess "loading wad" from options don't read dehacked

Indeed, Dehacked doesn't get loaded at runtime!

 

2 hours ago, Argenteo said:

Seems like it doesn't exist anymore. (Maybe I deleted it at the morning.)

Try without .plist maybe...

Share this post


Link to post

I've made a new build which will produce more useful information in the Console app when it crashes. If you get the crash again, please post the output from the Console app about Eternity for me.

 

EternityEngine-20220106-ab9e7c0.zip

Share this post


Link to post

I've updated the stickied thread to link to my own attempt at providing macOS devbuilds: 

 

Share this post


Link to post
Posted (edited)
5 hours ago, printz said:

I've made a new build which will produce more useful information in the Console app when it crashes. If you get the crash again, please post the output from the Console app about Eternity for me.

 

EternityEngine-20220106-ab9e7c0.zip

 

 

 

I deleted the old installation, downloaded this one, uncompress and move it to applications.
Started Eternity Engine.app and the launcher is there! How you made it??? Thanks a lot!

I'm going again to Eviternity 27 and finally finish that journey to heaven.

 

lC2BpQ1.png

 

Completed map 27 without any problem with that build. :)

Edited by Argenteo

Share this post


Link to post
Posted (edited)
7 hours ago, Argenteo said:

Started Eternity Engine.app and the launcher is there! How you made it??? Thanks a lot!

I've no idea. Either macOS did random stuff behind, I added a safeguard in the code or you managed to better delete the old data this time. In any case, I hope you'll get better crash reports in the Console app after an Eternity sudden termination.

 

Wait a second… is that Eternity macOS dialog box featured in Eviternity?!

Share this post


Link to post
Posted (edited)

Looks like he is playing HACX ... but HACX does not have map27 ...

Share this post


Link to post
8 minutes ago, hawkwind said:

Looks like he is playing HACX ... but HACX does not have map27 ...

 

Short story: I was playing Eviternity M27 and a crash corrupted my EE. I tried to reinstall it but failed. The starting interface not launched at all.
Printz made a new build and solved the problem. I made that funny screenshot with some HacX starting map and the interface running on the computer.

:)

Share this post


Link to post
On 1/9/2022 at 12:38 PM, Argenteo said:

 

Short story: I was playing Eviternity M27 and a crash corrupted my EE. I tried to reinstall it but failed. The starting interface not launched at all.
Printz made a new build and solved the problem. I made that funny screenshot with some HacX starting map and the interface running on the computer.

:)

Ah! Clever ! I should have looked more closely ...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×