Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ABirbWithGuns

Editor On Linux!

Recommended Posts

Alright yeah I believe we've found the problem. Just to expand a lil on what @Maribo said, 'root' in Loonix is the equivalent of administrator in Windows -- a higher access level that will allow you to actually modify the system outside of your personal home directory, ie. install things. Typing 'sudo' in front of console commands allows you to elevate your access level to root (never do this unless you have to though!).

 

Since you didn't know about this I'm going to assume that a lot of your problems were related to 'dependencies', which are stuff that needs to be installed in order to have the program actually work; when you dl a source port on Windows and it has SDL2.dll in the zip file, that's a dependency (Linux uses 'package managers' like apt so you only need to install the dependency once, while Windows programs usually include everything with them). When you compile stuff, whatever you're compiling will generally check if you have the dependencies installed and error out if you don't.

Edited by dmdr

Share this post


Link to post
18 hours ago, dmdr said:

never do this unless you have to though!

I find this kind of warning amusing because I've been a Puppy Linux user for years, and it runs everything as root by default, and while you can configure another, non-root user, that's highly advised against by the distro maintainers. I mean, Puppy is very much an oddball distro, but still.

 

My point is, even though root gives you a lot more power to completely break your system, most of the time running everything as root is actually not that bad. Not if you understand your system, at least. Root isn't dangerous, it has the potential to be, but isn't inherently dangerous.

Share this post


Link to post
16 hours ago, QuotePilgrim said:

I mean, Puppy is very much an oddball distro

 

yes

Share this post


Link to post
On 1/11/2022 at 10:24 PM, Maribo said:

I really don't know why you silently edited the terminal output screenshots into the OP (and also didn't crop them properly so they don't have a shitload of transparent space around them) instead of posting them in a new reply, man, but anyway:

sudo apt install eureka

This will run apt install as root. If this doesn't work, please post the error output instead of just saying "i tried it and it didn't work"

OK but how do i run it?

Share this post


Link to post
22 minutes ago, ABirbWithGuns said:

Oh.

At the behest of stating the blatantly obvious, is it in the menu now?

 

Before you say ''It is'' or ''It isn't, it didn't work'', describe the steps you did that lead to it working/not working.

Share this post


Link to post

I regularly compile and use Eureka on my Linux (and BSD/Unix/Illumos) systems without any issues.  If you follow the readme, have all the dependencies required then it goes through without issues.  However, you're using a pi (arm).  Eureka shouldn't have any issues though.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×