Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
birdmn510

Redrawing a linedef within a sector/ fuzzy wall

Question

Posted (edited)

I am working on my first Doom 2 map and I created a switch that I later decided to take out. As a result, the linedef the switch sector was built onto that is part of the larger sector defining the room was split into several uneven lines. I deleted these lines (after deleting the switch sector), drew a new linedef and placed it in the missing space between the vertices where the uneven lines had been. However, now, when I test the map, the section of wall where the new linedef is appears fuzzy and blinks/strobes when I move around the room. 

 

My question is, how do you properly redraw a line that is already part of a sector, and is there any way to fix my fuzzy wall problem?

 

I am running Doom Builder 1 on a Win 98 laptop that I play older games on. Also, I play Doom 2 in DOS mode, so I don't know how that affects things.

Edited by birdmn510

Share this post


Link to post

3 answers to this question

Recommended Posts

  • 1

You deleted a linedef and the sector then was missing a linedef? I think that at least in later editors, it tries to connect the previous vertexes to each other so that the sector remains intact. If the editor you're using just leaves the sector incomplete, I would try to avoid deleting lines, because a sector must be closed, and a non-closed sector will absolutely be glitchy. Instead, you can remove the tag and action special from the line, and move the vertexes together to remove that line that way. If you have redundant vertexes on a straight line, you can safely delete the vertexes.

 

I would suggest deleting your sector and recreating it.

Share this post


Link to post
  • 0
Posted (edited)
1 hour ago, birdmn510 said:

I am working on my first Doom 2 map and I created a switch that I later decided to take out. As a result, the linedef the switch sector was built onto that is part of the larger sector defining the room was split into several uneven lines. I deleted these lines (after deleting the switch sector), drew a new linedef and placed it in the missing space between the vertices where the uneven lines had been. However, now, when I test the map, the section of wall where the new linedef is appears fuzzy and blinks/strobes when I move around the room. 

 

My question is, how do you properly redraw a line that is already part of a sector, and is there any way to fix my fuzzy wall problem?

 

I am running Doom Builder 1 on a Win 98 laptop that I play older games on. Also, I play Doom 2 in DOS mode, so I don't know how that affects things.

 

That is quite cumbersome.

When you delete the linedefs all you need to do is reconnect the freed up vertices

 

https://youtu.be/w6SArqKM7uk

Share this post


Link to post
  • 0

I found only way to fix that issue is to merge the vertixes together into a linedef, so that new impassable linedef is created. Then recreate the sector you want.

 

For future reference: delete the line tag and action specials number. That will delete the action from linedef without reprecussion.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×