Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Need help with map...

Recommended Posts

Hi guys.

I started mapping... 3 days ago. And I have a simple designing problem. Sectors I mean. The level has a mirror-delirium effect because of unclosed sectors, and the worst thing is that I dunno how to close'em :(. Please, if somebody can help me. File is here:


If it doesn't work try punchen4.wad

Thanks overall,
The Eagle

Share this post

Link to post

I've just had a look at your wad, and it's pretty easy to sort out.
The first problem is that your outer linedefs (the ones that back onto the void) all need to be facing inwards, and the backs need to face sector -1. I've done this before, and in WadAuthor the only way to fix this is to rebuild the sector. There are a few other things which are easy to fix. I'll fix the wad so you can see what you need to do (I think that's going to be easier to do than making you read through a huge post). I'll post the link when I'm done.

Share this post

Link to post


Sorry that this isn't a direct link, but the server's being a bit odd at the moment. Click on the link on the page you're taken to.
This shows you what the was should look like without any errors. I've moved the door a bit, just to make sure you can get through it.
Just remember that all the outer linedefs must face inwards, with their backs facing sector -1. Also, no outer linedefs should be two sided, or you'll be able to walk right through them (in WadAuthor, two sided linedefs appear as grey lines, and outer linedefs as white lines).
Check the original with this one and you should be able to see where you went wrong.
Hope that helps you, and good luck with the editing :-)

Share this post

Link to post

Hmm. I have another problem. I copied the door you made to another corridor to have the connection with next sector, but I get a bad "hole-in-ceiling" effect. Also, how to make the wall up to the corridor when I have two sectors with different heights? Make the unpegged wall? I tried, but doesn't give effect.

The link, Gman, is:


Good luck and thx for help,
The Eagle.

Share this post

Link to post

hmmm... I think you need to download wad designers handbook, try search for it at google :)

Share this post

Link to post
theeagle said:

Hmm. I have another problem. I copied the door you made to another corridor to have the connection with next sector, but I get a bad "hole-in-ceiling" effect.


Ok, I've fixed the wad again, and there are now no more errors. I have no idea what editor you're using, so I don't know how you're creatign sectors (in WadAuthor it's automatic) but there were several sectors that were in two different places at once (that's why you were getting that hole in the ceiling effect).
The door was messed up because you copied it. There's no reason why this shouldn't have worked, but I generally stay away from copying doors directly to another area. Some of the door's linedefs were still linked to the original door, which meant that it was in two places at once.
Also, the ceiling height was messed up, but I have no idea why that was. After closing the sectors, the ceiling dropped to the height you'd actually set it at, which was too low to walk through. There was a ghost sector (one that wasn't cloesed) which was giving a higher ceiling level than the one you'd set.
You'll be able to see all the changes for yourself, of course. Hope that all helps! And definitely check out the DW editing tutorials.
Good luck :-)

Share this post

Link to post

Basically all the mistakes are:

1. Sidedef sector references were incorrect: Sector 20 and 23 and then a whole bunch of other linedefs.

2. There were -0- length lines, overlapping and dangling lines.

3. LD 48 has sidedef2 missing.

There were duplicate sectors in the wrong area per se. But there were other design issues that are not technical mistakes, but are "how it looks" mistakes - such as the height of a sector.

Punchfix2 changes fixed most of these, not sure if the teleport mod is now as intended, since the change made it all the same sector and you lost the teleport texture. What should probably have been done to the teleports was to just fix the sidedef1 sector references and that keeps the teleport flat there. The heights need to be adjusted though.

What you need to do is understand what "sector not closed" means. Basic concept is pretty simple: If you look at the side of a linedef and look at the sector number, then all the other linedefs that you can see (looking out from that side's direction) should have the same sector number on the sidedef facing you [excluding tricks].

The above probably sounds weird, but understanding this basic idea makes all problems much easier to fix - so spend a little time figuring it out and level making will be duck soup.

Some editors require less tinkering than others in the area of sidedef sector reference fixing - although it always will come up sooner of later:)

Share this post

Link to post

beezee88 sed

beezee88 heheh...

All these errors bring back bad memories of when I started out...

me too
I kept wondering what to do my, uncle fixed it 4 me

EDIT f*** should have used that quote thingy.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now