Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SepticDagger88

PrBoom+ giving me error message when using custom wads

Recommended Posts

Hey guys! I've been experimenting with PrBoom+ and for some reason I can't play custom maps with it no matter how hard I try as I always get this error message.

Screenshot 2023-11-09 145637.png

Share this post


Link to post

Are you able to run non-custom levels with it? What command line parameters are you using? Is it every wad you download? Which ones have you tried?

 

(Also, PrBoom+ has been retired for several months now and has been superseded by DSDA-Doom, which is its next continuation. While I doubt switching would fix your particular issue, no new features or improvements will ever be added to PrBoom+, and it's already fallen behind the curve in terms of what features are available in Doom wads these days.)

Share this post


Link to post
Quote

R_TextureNumForName: SKY3 not found

I expect the texture definitions from the IWAD have not been merged into your PWAD. PrBoom only loads the final TEXTURE1/2/PNAMES lumps it finds, it does not merge them all together (unless that has changed since they forked it).

Share this post


Link to post

That's another issue I have. I have no idea how to open the command line interface. I see youtubers simply click on the exe and it pops up but no matter what I do, it pops up with a launcher with all of the available wads in the directory instead of the empty command line.

Share this post


Link to post

Every WAD you download should include a text file detailing (among other thing) whether an advanced engine is needed to run it. PrBoom+ (and DSDA-Doom) are not advanced engines - they are basic limit-removing Boom ports. If the "advanced engine needed" is anything other than "Boom", "limit removing", or "no"/"vanilla", the WAD is (probably) not compatible with PrBoom+/DSDA-Doom and cannot be expected to run without errors.

Share this post


Link to post

the main wad that i use for testing is a simple room that i quickly made for well testing and it has no special stuff and it is set to use doom 2's format so it should work but the above error pops up

Share this post


Link to post

Are you using a third-party texture/resource WAD for your map? If so, what does its text file say about advanced engine requirements?

Share this post


Link to post

no its entirely vanilla textures and my custom textures including a custom sky which despite me checking in slade that they are formatted correctly, gives me an error when booting it up in prboom+

Share this post


Link to post

And its only 1 custom sky that has been corrected to Doom's pallet and format and it works in GZDoom but im using prboom+ for testing to see which source ports can run the map without issues

Share this post


Link to post
1 hour ago, SepticDagger88 said:

and my custom textures including a custom sky

Considering the error message specifically refers to a sky texture, this may have been worth mentioning earlier. Does your WAD's TEXTURE1 lump (or TEXTURE2 if present) contain a valid texture named "SKY3"? Because it needs to even if your map doesn't contain any sky sectors, as Doom unconditionally attempts to load the hardcoded sky textures when starting a new game.

Share this post


Link to post

Also, what format is the texture? Has it been properly converted to Doom format, or did you just import an image file without converting it? That would explain GZDoom being okay with it while other source ports aren't.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×