Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  


Recommended Posts

I can't figure out how to run a map with Zdoom. Map <name> doesn't work. And ZDlauncher doesn't help either. So how do i run a map? :/

Share this post

Link to post

Are you loading up the wad at the same time as you start the program? e.g. from the command line (works for all exes) or drag-and-drop (works AFAIK for all ports based on one of the later versions of Boom)?

Typical command line (to load hr.wad):

zdoom -file hr.wad
Then start a game.

Share this post

Link to post

I just tried your method Julian, and then Zdoom crashed.

And Grazza: My zdoom.exe only has "General" and "Version" tabs in the properties.

Unless it requires v1.23, if so, could you send me a link because i can't find it anywhere.

Share this post

Link to post

Create a shortcut to your ZDoom program, right click, click on Properties, then click on Shortcut, at the end of the line where it shows what directory ZDoom is in, type -file whatever.wad (note that you don't have to add the .wad as ZDoom will automatically do it).

Share this post

Link to post
Mivalekan said:

My zdoom.exe only has "General" and "Version" tabs in the properties.

That doesn't matter. Basically what you're doing is just using an old-fashioned DOS command, like it was when Doom first appeared. In Win95/98/2000/XP/whatever, you click on the Start button, and then on Run... Just type your command into the box. You will need to give a path for the folder where you have Zdoom. Assuming it is in c:\doom2, and the wad you want to play is in the same place (and let's assume this time it's called equinox.wad :) ), then you would type in:

c:\doom2\zdoom.exe -file equinox.wad
That should work OK.

Someone is bound to comment that the "-file" is unnecessary with Zdoom, and that the ".wad" extension is also unnecessary. That is true, but some ports require them, so I have given the more general version, on the assumption that you might want to use other ports too (in which case replace "zdoom" with "eternity", "prboom", etc.).

Drag-and-drop should work no problem though (as long as the wad isn't specifically for some other port, I suppose). Have you extracted all the files from the zdoom cab (zdoom.exe, zdoom.wad and fmod.dll) into the same folder as your doom2.wad?

Share this post

Link to post

I'm lazy, I have .wad files set to open with zdoom. :)
I try to avoid using .deh files, I hate having to take a couple seconds extra to play doom.
I kid about the deh.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this