Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
JoelMurdoch

Weird Outlook Express bug - anyone else experienced this?

Recommended Posts

I'm at work trying to code an email confirmation of order into my shopping cart. The upshot of this experiment is that I've discovered that the latest version of Outlook Express (I use Thunderbird for my own mail) on my system renders all messages, be they sent by itself or PHP, as attachments. I've tested this with two different servers and got the same result. Thunderbird renders these same messages with no problems.

Has anyone else experienced this?

Share this post


Link to post

No, but it sounds like either "malformed" MIME encoded parts or it's PGP-encrypted or some such.

Share this post


Link to post

Thanks for the reply Arioch. That was what I initially suspected myself, but one server I tested was a national and popular ISP. One would expect they would know if there was a server side issue involved.

It even affects plain text. Here's the source of a plain text message sent by OE itself to said ISP and back.

Return-Path: <joeltest@ihug.co.nz>
Delivered-To: joeltest@backend.pop.ihug.co.nz
Received: (qmail 9985 invoked from network); 2 Mar 2004 20:44:31 -0000
Received: from grunt7.ihug.co.nz (203.109.254.47)
by mail2.ihug.co.nz with SMTP; 2 Mar 2004 20:44:31 -0000
Received: from (Laptop) [202.49.94.147]
by grunt7.ihug.co.nz with smtp (Exim 3.35 #1 (Debian))
id 1AyGkf-0004gl-00; Wed, 03 Mar 2004 09:44:29 +1300
Message-ID: <002701c40097$3ed6c220$e400a8c0@Laptop>
From: "ihug Test" <joeltest@ihug.co.nz>
To: <joeltest@ihug.co.nz>
Subject: test
Date: Wed, 3 Mar 2004 09:45:06 +1300
MIME-Version: 1.0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165

test


I'm no expert on MIME headers but that looks fairly standard to me. I even disabled AVG's E-mail scanner - no change.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×