Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ZDaemon crashes with MAPINFO lump

Recommended Posts

Ok, there's a new problem.
I made a wad and added a MAPINFO lump with new map names, using XWE. Everything was fine with Unleashed. The game ran well and the new map names were shown correctly.

Then I opened a server at ZDaemon with this wad.
I ran across a "start crusher"-line, and the server broke down.
I tried again, opened a door, and the server broke down again.

Seems that- with this mapinfo lump- every activating of a linedef action makes the server crash.

I eliminated the lump and everything was ok.

The mapinfo lump was this:

map 01 "aries"
map 02 "taurus"
map 03 "xy"

What's wrong with that?
The wad is in ZDoom, Doom for Doom format.

Thanks for help.


Share this post

Link to post

It's because you don't have the correct format. Later versions of ZDoom are a little more forgiving than ZDoom 1.23/ZDaemon.

Try this:

map map01 "aries"
map map02 "taurus"
map map03 "xy"
Also, I think it helps if you manually define each sky.

And don't let this deter you from mapping for ZDaemon, you just need to be aware that it's simply ZDoom 1.23 with netcode (and CTF...soon).

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now