Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
DooMBoy

Little help here

Recommended Posts

Hello, just a little help here and I'll be well upon my way :)
Currently, I'm using Deep 11.76, and I want to do a ZDoomHeretic map. But when I choose ZDoomHeretic.prj as the project file, and point Deep to the converted IWAD in my Heretic folder as the main IWAD it flashes a long list of missing linedef types and such, then it sends me back to normal Heretic mode.
I seem to recall there was a way around this, but I've forgotten it.

Share this post


Link to post

Download this file:

http://www.zdoom.org/files/utils/utils050999.zip

After extracting you will find a file named zdwadconv.exe

From the zwadconv.txt file:

Usage: zdwadconv <source.wad> <output.wad>

This program converts every map in the source.wad into the
enhanced format supported by ZDoom. This is essentially what
the game does when it loads a normal Doom map. However, Zdoom
is free to use certain tricks which this program can't, so it
is possible that some maps will not convert successfully.
this is an external utility, it may not be possible to
convert every map perfectly. The file convlog.txt will
contain a copy of every message printed to the screen during
the conversion and should be checked if something went wring.


Use it on HERETIC.WAD thusly:

zdwadconv HERETIC.WAD ZDheretic.wad

Personally, I like to rename the converted Iwads to ZD... just to keep them all straight.
And that should do the trick.

Share this post


Link to post

You don't understand, I have the IWAD converted to ZHeretic.wad, and I'm using that as the main IWAD for ZDoomHeretic.prj. Why it won't work is a mystery.

Share this post


Link to post

I just went through the process of setting up DeepSea for ZDoomHeretic and all went well. Mostly.

During zwadconvert I got a "Sector tag 999 is unreferenced" message for most levels. And when starting DeepSea,
I got a "Line with invalid Floor property" message, but the editor started and the map displayed ok.

So, it does work. Maybe you should reinstall your copy of DeepSea?

Share this post


Link to post

No, I remember that there was something 'turned on' in Deepsea that gave me trouble before when I tried doing a ZDoomHeretic map.
I also remember Deep told me what it was, and how to turn it off so ZDoomHeretic worked correctly.

Share this post


Link to post

There was a typo for line special 139 in ZDOOMHERETIC.OPT. There are 2 quotes in a row, remove one of them. I fixed this for the DOOM version, but forgot about the HERETIC one. New version 11.83 also does more syntax checking vs older versions, hence older version won't bitch about this:)

IIRC, the only thing that's special for the older versions is that after you switch projects you need to exit and restart. It just gives those messages 1-time. New version no longer requires you to do this.

In F5 - you need to have the correct OPT file (ZDOOMHERETIC.OPT) and you need to check the ZDOOM-HEXEN box (just means that you are operating in HEXEN format).

Share this post


Link to post

Heh, I figured that out last night as I was fooling around trying to get it to work. Thanks anyways :)

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×