Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
marky

the DECORATE lump

Recommended Posts

Hi, all!
I have built a map in which I replaced the sprites of one monster (demon). That works fine.
Now i want to replace the obituary message "player was killed by a demon" by my own message.
The map is encoded in "ZDoom, Doom in Doom" format. I read about the DECORATE lump. So, I opened the wad in XWE, made a new entry DECORATE and wrote:

actor demon 3002 {
Obituary "%o was killed ..."
}

But when I tried to save it, XWE said, it couldn't save. The DECORATE entry is also named a "MARKER" instead of a lump.

So, my question is:
Is it possible, to change this one special message in "ZDoom, Doom in Doom"-format without using Dehacked? If so, how do I have to do it? If it should work with the DECORATE lump, what did I do wrong?

Thanks for help,

Marky.

Share this post


Link to post

Try making a text file with what you want in it first, then import it into the wad. XWE is weird sometimes about saving some things. Although I am not sure if you can change existing monsters with decorate.

Share this post


Link to post
Graf Zahl said:

You can't!


I thought so, my mind was asleep earlier.

nothing can stop you from doing this though:

actor newdemon : Demon 90
{
Obituary "%o was killed ..."
}
Then just replace all the demons in your map with thing number 90

Share this post


Link to post
KoRn said:

I thought so, my mind was asleep earlier.

nothing can stop you from doing this though:

actor newdemon : Demon 90
{
Obituary "%o was killed ..."
}
Then just replace all the demons in your map with thing number 90



When I do this, Unleashed says:
'script error "decorate", line 1:
unknown game type newdemon'

Share this post


Link to post
marky said:

When I do this, Unleashed says:
'script error "decorate", line 1:
unknown game type newdemon'



Get the latest version. You get this error with 2.0.61 or earlier.

Share this post


Link to post
Graf Zahl said:

Get the latest version. You get this error with 2.0.61 or earlier.


oh, i see...
as it is a deathmatch wad which i will run on zdaemon, it won't work there, right? zdaemon seems to run an older version of zdoom, too...

Share this post


Link to post

ok.
now i managed it with the dehacked lump. that was quite easy.

thank you for your help and the hint with the darkhour.wad

marky

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×