Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Help! DVD drive with identity crisis :(

Recommended Posts

Basically, my DVD drive will read and play CDs absolutely fine, be they audio or data. But put an actual DVD in it, and it won't even recognize it, where it's data or video.

I've done all the usual checks: has Windows set it to be PIO only rather than DMA (no), is there an ASPI layer (yes), are the DVDs in question dirty/scratched (no, and I've tried a lot of different DVDs in it anyway), etc. Heck, if I run Nero InfoTool it actually comes up with the name of the DVD in the drive.

The only thing I can think it might be is the driver. It's using the generic "IDE DVD-ROM 16x" Windows driver, as the drive came with the PC. I'll open up my case and see if I can find it's model number or something, but I figured I'd post here first in case anyone could think of anything else that might be causing this.

The DVD drive (F:\) is the secondary slave, the secondary master (E:\) being a CD-RW drive and the primaries (C:\ and D:\) two hard disks (40gb and 120gb).

BTW I'm using Windows 2000 with DirectX9.0b, all the latest drivers for my 3D card (Radeon 9700), soundcard (Audigy 1), etc. I used to use Win '98, and the DVD drive ran like a dream in that. Until now, I don't actually remember ever trying to play a DVD since installing Windows 2000, so it may well have been screwed up then.

EDIT: oh yeah, normally the computer just comes up with "Please insert a disk into drive F:\", but sometimes it seems to be trying to read the disc but reports "F:\ is not accesible. Incorrect function."

Share this post

Link to post

i don't think it would have anything at all to do with direct X or your video card. it could be the settings or prehaps the drive is damaged/dirty.

try reinstalling the drivers. also, maybe check region settings. i know my brother had that issue with his. he had set it to the wrong region.

Share this post

Link to post

It's a driver problem. Chances are you need a new DVD drive. Happened with me too :(.

If it's a Pioneer Drive you should replace it with a another drive.

Share this post

Link to post

Try the drive on the secondary IDE bus by itself. Sometimes older DVD drives need to be the only drive on the bus to work correctly, or just be the Master. As Bloodshedder mentioned, a firmware upgrade can sometimes resolve that issue.

Edit: It has absolutely nothing to do with drivers, I can tell you that. The ATAPI system controls all CD-ROMS without drivers.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this