Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
netnomad312

Zennode acting strangely

Recommended Posts

I never used to use Zennode, because I would have to run from the command line, which was a pain in the ass. So I included in a program of mine (a port launcher of sorts which also includes tools and a quick-launcher for some programs, written in VB6) a Zennode quick launcher. When run, it should accept the wad name you typed into its box, followed by any extra parameters stored for Zennode by my program (saved in an INI). Lately Zennode has been doing things that are weird. For instance, I ran it on my Legacy map, and then used my program to launch Legacy to test it (with the "opengl" checkbox on). It appeared to be full of GL holes, as if I hadn't run Zennode on it at all. I had; I watched the DOS window appear, and then disappear after it finished the reject... just like always. I couldn't figure out why it wasn't working, until I noticed later that a file called [mywad].wad.wad existed in my C:\ drive. It put the result there instead. I deleted this file and tried again, and this time it worked. But the next time I tried to build... same problem. This time, even after deleting the misplaced copy, it still won't save correctly. Hell if I know where the file is now.

I checked the strings that were being sent (I keep many of my wads in my Doom95 folder; don't ask):

Path: "C:\Program Files\Doom II for Windows 95\ZenNode.exe"
Parameters: "C:\Program Files\Doom II for Windows 95\mywad.wad "
Directory: "C:\Program Files\Doom II for Windows 95\"

I would guess that it's the spaces in the path that screws it up, but I already included fixes for this; those are full strings, which include the quote marks. So there's absolutely nothing wrong with them. Is this some weird behavior of Zennode?

Share this post


Link to post

First you need to specify an output file. Even if it says you dont need to, you still should because it could goof up here and there. Adding "" around the filename I have never gotten to help me much, try moving the wad into a "build" temp directory with zennode in it, and run it there. Make it a DOS friendly name like C:\build or similar. You get the idea. As for your holes in Legacy OpenGL, that doesnt suprise me. When you build the nodes, use a splitfactor of 64, that one runs best with Legacy. Also dont snap the vertexes to a grid smaller than 8. If you use a low splitfactor, like 8 or 16, you will get alot of bugs. This is why so many older maps from "the day" look so horrible in Legacy OpenGL. It would really help if the Legacy guys would implement this thing called "GL Friedndly Nodes". If that doesn't help, tell me. Also check your frontend program, it seems to be bugging out a little too.

Share this post


Link to post

I'm certain the program is working fine and that the names work. I once had problems with the source ports themselves not reading the DOS-unfriendly names right, but I solved this by adding Chr#(34) around the edges of the string. I will try that output thing though... I may as well write that into the default string too. Hey, if you have more than one -o or whatever, which one does it listen to, the first or the second?

Share this post


Link to post

only use -o once. You only need(and can only) to specify one output file. If you specify multiple output files, it won't work. Example: zennode yourwad.wad -o outwad.wad -o outwad2.wad is an accident waiting to happen. Sadly, you will have to do it like this: zennode yourwad.wad -o outwad.wad and copy outwad.wad and rename it to outwad2.wad (forgive me if the command line paramaters are wrong, it's been a while since I used zennode from the command line.)

Share this post


Link to post

Actually, the string I created ends up basically like this: [quotemark] + [directory name] + [textbox contents] + [quotemark] + " -o " + [quotemark] + [directory name] + [textbox contents] + [quotemark]

So the result, though long, for me would be
"C:\Program Files\Doom II For Windows 95\mywad.wad" -o "C:\Program Files\Doom II For Windows 95\mywad.wad"

This works, thanks for telling me about that bug.

Share this post


Link to post

I have learned from another that we can just "drag and Drop" a wad onto the ZenNode.exe icon and it will build the nodes.

Share this post


Link to post

Yes, I just learned from Deepteam that doing so bypasses all the options, so not the best way to do this.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×