Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
adeangelis

Help!!! Doom 3 is running slow!!!

Recommended Posts

Hi, I just purchased Doom3 and I am having some issues with the framerate. I am average about 18 FPS, and when there are monsters in the room, I only get about 9! I have tried the .PK4 unpacking and the modded config file, but they haven't helped. My PC Specs are:

P4 2.4 GHZ 500 MHz FSB
768 MB PC 2700 DDR
250 GB 7200 RPM WD HDD (50 GB System Partition)
Geforce FX 5200 128MB Ram (Overclocked to 325 MHz Core/440 MHz Memory)

Any help would be greatly appreciated.

Thank you.

Share this post


Link to post

Your 5200 graphics card probably isn't helping a whole lot. But yeah what settings are you running it at? Try Low if you haven't already, and turn some stuff off in the advanced options (specular highlights, bump mapping etc.).

Share this post


Link to post

I'm running at 640x480 with Medium Settings. What do you mean my 5200 isn't helping? Even still, it shouldn't be running that slow.

Share this post


Link to post

Well what I mean is, the 5200 isn't that great a card, and gives out performance equivelant to a GeForce4 MX 440 from what I've experienced. Something like a 5600+ would give better performance.

Frankly, you're doing pretty well with an average 18FPS. If you want more speed, either upgrade your video card or lower the in-game detail.

Share this post


Link to post

I lowered it to Low detail and turned off all advanced options, but it made no difference. There must be a way other than "upgrading your video card." Not all of us have that much money to throw around.

Share this post


Link to post

I'v got pretty decent fps with my 5200 on medium detail the goodies on and 640/480.

Share this post


Link to post

I found out what the issue was! I had accidentally downloaded the driver update from Windows Update. When I did that, it dropped my FPS to like 4! I downloaded the latest and greatest from Nvidia, made a few changes (like manually setting the GFX card size in the DoomConfig.cfg file. Apparently, Doom 3 doesn't detect it properly. It said I had a 64 MD card when I really have a 128.), and voila! I am now getting a consistent 34-40 FPS.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×