Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Delta Labs sec 3 HELP!

Recommended Posts

Ok, so im in section 3 of the delta labs which has the bridge thats been melted. I've tried a dozen times to jump across, but it hasn't worked. Ive gone through the entire map 3-4 times as well as used all the teleporters. The only place I cannot get into is security station 3, which the pad on the door says unlocked, but the red light around the door wont let me in(?). I'm exhausted and frustrated, anyone got any suggestions?

Share this post

Link to post
XIInine said:

Ok, got it. Master you can suck a fat one kid.

He tries to help and thats the thanks he gets? Oh my..

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now