Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

boot issues

Recommended Posts

i know, this aint a hardware thread. however i have only asked at numerous boards with no luck.
is this question really that damn difficult or are people just being difficult??

anyways i have linux installed on a 120GB drive, windows installed on a 20GB drive. i installed windows on the 20GB with no other drives present. then i added my 120GB drive and slaved the 20GB to it. i then installed linux on the 120GB drive. however lilo, or grub, will not boot windows at all. gives "loading windows" and stays stuck.
here is the lilo config data
# Modified by YaST2. Last modification on Sat Aug 7 18:02:05 2004

message = /boot/message
timeout = 80
default = Linux
boot = /dev/hda

image = /boot/vmlinuz
###Don't change this comment - YaST2 identifier: Original name: Linux###
label = Linux
initrd = /boot/initrd
root = /dev/hda1
vga = 0x317
append = "splash=silent desktop resume=/dev/hda2 showopts"

other = /dev/hdb1
loader = /boot/any_d.b
###Don't change this comment - YaST2 identifier: Original name: Windows###
label = Windows

image = /boot/vmlinuz
###Don't change this comment - YaST2 identifier: Original name: Failsafe###
label = Failsafe
initrd = /boot/initrd
root = /dev/hda1
vga = normal
append = "showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 3"
i have never really messed with the lilo config files. a linux book i have told me to add this line "loader = /boot/any_d.b" have no idea what that does. and no it didnt work.

also windows will not allow itself to be installed on a slave drive, so maybe it has issues booting from a slave disk. in that case i dont really see why it should, and that someone would have come up with a way around it.

as of now i use windows for a few games, doom3 and SH3. othewise i would not bother with it. so any ideas on how to fix this?

note: useing suse 9.1 and windows 2000. Windows will boot if i remove the linux drive and set it as master. mind you that is annoying if i feel like playign doom and want to switch back into something for linux. also when setup, i can still read the windows partion and such. both drives are fully working.

Share this post

Link to post

I haven't done to much with Linux but I know that Windows is not about to let Linux on the system without a fight :D Windows is designed to make it hard for other operating systems and I could see Microsoft not allowing Windows to be installed on a slave drive, to take precautions.

Share this post

Link to post

yea i tried installing on a slave once. however it was installed as a master.

also no part of linux is on the windows drive nor is any part of windows on the linux drive. as for getting arund that issue i am sure ther are people with a similar setup.

Share this post

Link to post

Try and see if you can boot from the slave by pressing a button at boot rather than using software. In my computer I press F6 and it will give me a list of drives to boot from. The only time I do this is to boot into Windows 98 on my slave, and it works just fine.

Share this post

Link to post

that i beleive is the windows boot loader. also i have seen a similar function on IBM systems at work. i belive windows can, and will never, boot as slave. more MS BS.

however there has to be a way to trick it.

i dont know if it is really a good idea to slave a 120GB drive to a 20GB. also i could simply have the 20GB on a different channel or use a external card. however i think i would have a similar problem

Share this post

Link to post

I think the one you're thinking of is when you press F8 and it asks what mode you want to boot into, like normal or safe mode. This is a function built into the BIOS I think. The only time I press F6 to do this is to boot from IDE 1, which is my primary slave, with Windows 98 installed. When I'm under windows 98 it thinks that the slave is C:\ and the master is D:\, which is perfectly fine with me. :)

It may just be Windows XP throwing a fit, but I've never tried to boot into it installed on a slave.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this