Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
FantomBlu

Red/White Dots Everywhere

Recommended Posts

Ok..anyone else getting Red and white little blocks all over the screen while playing?? I am pretty bad. I've tried several things. Turned down the core clock speed. (This only distorted my main doom menu to a fuzzyness). I've tried the 2 beta cat drivers...nothing...turned off fast writing in smartgart..and set it to 4x...and still the "strawberries & cream" (as I've come to call em) all over the place. I'm 99.5% posotive it's not heat related..as my case has good airflow..and no other games at all are having this problem.


Any suggestions? or is anyone else having the same problem?

System specs

P4 3.0ghz
2gig RAM
Radeon 9800 256k
Cat version 4.7 (currently)

Share this post


Link to post
rezolution said:


Looks like the only constant with this bug is the ATI 9800. It has nothing to do with overclocking or overheating. I have been able to reproduce this bug with TWO (2) ATI 9800 cards.

Share this post


Link to post

Yeah rezolution that pretty much what I've been seeing..not quite as bad as yours tho. I get red dots all over as well..when something in the room is bright red or orange.

Share this post


Link to post
FantomBlu said:

Yeah rezolution that pretty much what I've been seeing..not quite as bad as yours tho. I get red dots all over as well..when something in the room is bright red or orange.


I found out that a LOT of people are affected with this bug. This is disturbing as I did not expect ID to ship a bugged game. ATI Radeon 9800 is a very popular card and ID should have tested their software with this card thoroughly before the releasing the game.

Share this post


Link to post

Just a tip: ATI has released a beta version of the 4.9 Catalyst drivers, specificallyfor Doom 3. It supposedly raises the FPS a little and may fix the dots. Keep in mind that these are beta drivers and are not supported whatsoever until the official drivers are released, which should be within a month.

http://www.ati.com/support/infobase/4547.html

Share this post


Link to post
alexz721 said:

Just a tip: ATI has released a beta version of the 4.9 Catalyst drivers, specificallyfor Doom 3. It supposedly raises the FPS a little and may fix the dots. Keep in mind that these are beta drivers and are not supported whatsoever until the official drivers are released, which should be within a month.

http://www.ati.com/support/infobase/4547.html


I know about the beta drivers, but I am not one with the time or patience to mess with unsupported releases.

Has anyone with similar problems had success with the beta drivers?

Share this post


Link to post

I finally fixed it. I just used rage3d tweaker to lower my core clock speed by 7-12 MHz. I get little to no dots anymore. (save for a few little black boxes popping up) And I'm none too happy about it. There's really no performance slowage now, but it's the simple fact that I HAD to lower my core speed in the 1st place :/ I shouldn't have too :(

Oh..and has anyone elses main menu and all text become REALLY blurry?
Just wondering..because now mine is this way :(

Share this post


Link to post
FantomBlu said:

I finally fixed it. I just used rage3d tweaker to lower my core clock speed by 7-12 MHz. I get little to no dots anymore. (save for a few little black boxes popping up) And I'm none too happy about it. There's really no performance slowage now, but it's the simple fact that I HAD to lower my core speed in the 1st place :/ I shouldn't have too :(

Oh..and has anyone elses main menu and all text become REALLY blurry?
Just wondering..because now mine is this way :(


Not worth it man.

Share this post


Link to post

Mine started as just red and white dots and it has just become increasingly worse. I can't even play the game like this. Very upseting but there should be a fix for this sooner or later.

Share this post


Link to post

i have a 9800 XT 256mb

dont have a problem (first running on the almost newest drivers from ATI, then ran again with the Omega drivers. both worked fine).

Share this post


Link to post
FantomBlu said:

Oh..and has anyone elses main menu and all text become REALLY blurry?
Just wondering..because now mine is this way :(


This is probably because you have lowered the quality settings in the Windows display control panel for OpenGL.

Share this post


Link to post
Godshatter said:

i have a 9800 XT 256mb

dont have a problem (first running on the almost newest drivers from ATI, then ran again with the Omega drivers. both worked fine).


Do you use a CRT or a LCD screen? I have a 9800XT 256mb and use a LCD screen. If I switch to my tiny CRT screen I get far less red/white dots, but they are still there.

Share this post


Link to post

Hey FantomBlu I got rage3d and did what you said and it worked like a charm. I've started the game over so I can play without the dots. Thanks alot man.

Share this post


Link to post

I just installed the new Directx9.0c and it helped with the white dots a whole lot. I still see them in some really dark areas but there much smaller.

Share this post


Link to post

I used to get the white dots in HALO and found out it was in the advanced settings. TURN OFF - ENALBE SPECULAR. Choose "NO" on this. It should solve the white dot problem. hope this helps.

Running with:

Shuttle XPC
AthlonXP 2.4Ghz (barton)
1 Gig 3200Ram
ATI Radeon 9800 128MB (latest drivers)
1280x1024 Resolution

And everything looks pretty sweet!

Share this post


Link to post

I am getting snow on my screen? I have a AMD 2.5 Oc'd to 3.2 ATI Pro9800 256mb card. 512mb ram.
What is going on. I get it sometimes and sometimes I dont. I can seem to find the cause. Help.
THanks

Share this post


Link to post

I had this problem, but my card was overclocked. When I bumped the core speed down a few MHz, it went away.

This can happen even if your card isn't overclocked. Of course it _shouldn't_ happen if the card is properly cooled and not overclocked, but if you are seeing this kind of artifacting it is a pretty clear indication that the core is running too hot/fast. Just give it better cooling, or (easier and cheaper) downclock the core a little bit.

Share this post


Link to post

I have a 9800 pro, no problem, but mines not overclocked.. and i havent updated my drivers at all...

Share this post


Link to post

The beta drivers dont fix it, and underclocking only helped for a short period of time. Has anyone tried the TURN OFF - ENALBE SPECULAR option? Its not me having this problem, its a clanmate, im just doing what i can to help.

Share this post


Link to post

I just tried turning off the Specular....didn't do shit. Hell, it almost seemed worse. I've got a 9800 XT, btw - same as most of you guys. I've tried just about every driver out there.

In addition to having the Specular off, I also turned AA off, and ran on medium graphics with 800 x 600 resolution. AGP was set to 4x, with fast write off. In short, I cripled my system and it didn't do jack fuck for me. Why the hell does it have to be me...fucking ati.

Share this post


Link to post

I have a Radeon 9800 and I had the same problem. I installed windows Service Pack 2 yesterday and now the game is working just fine!!! I also unpacked all the .pak files in the game like someone said in a post on the forum but all that did was increase the game speed (but now the game directory is HUGE). anyway, just install Windows Service Pack 2 and the game will work fine, at least for me it is

Share this post


Link to post

yo was really pissed off when first tried to play doom 3. white dots everywhere and crashes after 5min of playing. after reading numerous posts here i did the workaround below which fixed ALL problems. now the game runs absolutely smooth and stable (1024x768, high quality).

* installed directx 9.0c (reduced dots)
* re-instlled catalyst 4.7
* disabled fast-write

-> at this stage the the crash problem was fixed and the dot- problem was reduced significantly but the performance was not very satisfying.

* did ATI workaround as posted already in other threads:
http://www.beyond3d.com/forum/viewt...4874&highlight=

* made the cache adjustments in doomconfig.cfg as posted in this thread:
http://www.doomworld.com/vb/showthr...&threadid=26178

-> these changes have greatly improved the performance of the game.

it was mentioned in several threads that the dot-problem might be caused by overheating. although the problem was almost gone i've still had the impression that the cooling of my system could be improved. i opened the case and noticed that the soundcard was just beside the graphicard, almost touching the gra-cards fan. so the soundcard was moved to the slot most far away and i've also removed the PCI-slot covers to get more air. this has finally completely eliminated the dot-problem and the overall system-stability has improved...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×