Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
VinceDSS

Reduce Lag with vanilla doom EXEs

Recommended Posts

In my quest to make the original Doom EXEs run lagless under WinXP I found a pretty cool tool.

The old EXEs always have some kind of lag while playing even w/o sound. Some people told me it might be related to a low priority level, making the game use less system resources (hence lag).

So I found Cacheman XP... besides imporving the use of your RAM it also allows to set different priorities for your applications. So I set a high priority to XP's DOS prompt (called cmd.exe in your task manager). And the lag got noticably lower :)))

Over that you can use SoundFX2000 or VDM sound to emulate a SB16, but it tends to bring back a little lag.

If you have any more ideas on running the Doom EXEs smoother, pls let me know :)

(like making the mouse input a high priority too, if not already)

Share this post


Link to post

Maybe it's related to my system... it's a laptop with chipset video .. so VGA and some other legacy DOS features mightbe lousyly supported.

Share this post


Link to post

maybe you should just use a source port!

winXP has LIMITED dos support. so it may or may not work. if you want original like play just use boom. there is already posts about doom and windows. also i am very aginst useing the doom95 port, simply put just use boom, prboom or zdoom.

I dont recomend DOS emulators either. many are still beta or alpha. also they too have issues with doom. you can always set up a system for older DOS based games, or have dual boot settings

Share this post


Link to post

Maybe you don't get me, I use ports for casual play : with savegames, high res. and special wads.

But when I want to record something for the Compet-N, I need to use doom(2).exe ... and WinXP has way to much lag... I am just trying to improve that.

Btw, I'll get an old P200 from work, no sound tho.

Share this post


Link to post

yea for demos i understand. however you should know that doom2 and winXP dont work together. just use the older system or dual boot, its less of a headache in the long run. you can get an extra sound card for cheap. however the best card for those old DOS games was the AWE64

Share this post


Link to post

Seph, uh... you realize you are talking to Vince. (ie. someone who knows more than you do about this subject)

Share this post


Link to post
Sephiroth said:

maybe you should just use a source port!

winXP has LIMITED dos support. so it may or may not work. if you want original like play just use boom. there is already posts about doom and windows. also i am very aginst useing the doom95 port, simply put just use boom, prboom or zdoom.

I dont recomend DOS emulators either. many are still beta or alpha. also they too have issues with doom. you can always set up a system for older DOS based games, or have dual boot settings


I never understood your hatred for doom95. I love it. I just don't like that it lags whenever a spectre is right in front of you. But that's the only bad thing I have to say about it. For playing vanilla wads and such it's wonderful (to me)

Share this post


Link to post

A friend of mine said he got the sound working under XP, though i dont quite remember how (he knows tons about computers, but he doesnt know the correct terms for things, he reckons you can block ALL viruses by "turning off macros"), something about "setting the sound card to 16-bit". If you ask me he got it working by blind luck

Share this post


Link to post

Raziel said:
I never understood your hatred for doom95. I love it. I just don't like that it lags whenever a spectre is right in front of you. But that's the only bad thing I have to say about it. For playing vanilla wads and such it's wonderful (to me)

Try it with the command -emulate and let me know if you see an improvement. You can add it in the launcher or use the command line adding -nodm (which will make Doom95 ignore the launcher.)

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×