Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Doom worked fine... put new vidcard in... now it doesn't.

Recommended Posts


I bought Doom 3, played it absolutely fine on my P4 2.8, 2 gigs of RAM, and a GeForce 4 TI 4600. Had no problems. I had a 6800 Ultra already on the way, however. I put the 6800 in. Most of the games I tried weren't working quite up to snuff. Unreal Tournament ran fine. Battlefield: Vietnam loaded up and was running at about 10 FPS. The recently released demo for Rome: Total War ran absolutely beautifully, though.

Confused, I tried Doom, and the loading screen comes up... and then I hear the opening iD software cinematic even though it still says 'Initializing Menus.' The movie sounds end, then the screen goes black, and I see the menu mouse, which I can't move. And nothing happens. So, figuring it was the fact that I don't have my new powersupply (Enermax 550W on the way) I took the 6800 out and put the 4600 back in.

Now, with 4600 back in, I assumed everything would work normally. Doom still does the exact same thing. BF Vietnam won't even go to the main menu and neither will UT2k4. Yet the Rome: Total War demo still works fine. Sloewr, as it's a slower video card, but fine.

After several different failed attempts to fix it, I just saved some stuff, nuked C-Drive and reinstalled XP. Doom still does the same thing. I reinstall everything from scratch on my gaming drive, format it, reinstall Doom 3... and now it still does it. I have no idea where to even look about solving this problem. Any help would be hot.

Share this post

Link to post

Yeah, forgot to mention. I do have DirectX 9c and the absolute latest Nvidia drivers. 61.77. I've uninstalled and reinstalled the drivers and tried past versions. It doesn't make any difference.

Share this post

Link to post

That is about the exact same problem like I have had from te beginning.

Haven't been able to play at all.

Difference is that I have this problem with my Ti4600.

Tech support is clueless :-(

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now