Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
sriram

Doom 3 on my FX5200

Recommended Posts

OK,this is stupid,playing Doom 3 on a 128MB FX5200 and expect good framerates is very idoitic....but getting 10.2 FPS in the timedemo (at medium detail - 640x480,the "optimsed seettings" for my PC)...is very bad!

Here is my config: P4 2.4c,FX5200 128,Intel 865 Motherboard,512 MB DDR RAM,80 GB HD running Win XP Prof.

I've installed Doom 3 on my C drive(8 GB Freespace).I've defragmented my harddrrive and there arent any background apps,spyware,viruses etc etc.Far Cry,Painkiller,UT 2004,Max Payne 2 and other (current)hi-end games run fine(decent 30-45 FPS at high-detail) on my PC...but Doom 3 is very slow!
I mean my config exceeds the minimum system requirements,so I expected atleast 25 FPS...but all I get is ~20 FPS in empty places and ~7 FPS with more than 3 monsters on screen...this isnt completly unplayable(I'm already in "Alpha Labs - Sector 2" and I'm enjoying it)...but a smoother framerate would enhance my experience...

I've tried turning off all the advanced options(shadows,bump maps etc),tried setting the "Image Settings" to "High-Performance" in the videocard settings,tried many "Doom 3 Tweak Guides"...but I got a mere 4 FPS increase in the timedemo(and the visuals look horrible in the low details)..

So,any suggestions to increase the framerate (other than asking me to dump my FX5200 and buy a new card.I'm not rich enough to buy a new card every 6 months..and I bought my FX5200 only last year hoping to play Doom 3 and Half-Life 2 on it) would be helpful.But if this is how any FX5200 runs Doom 3...then I guess I have to stay happy with my current framerate..

Share this post


Link to post

Heh, your card should not be causing the problem. I have a P4 2.6 512K L2, 512MB ddr333, MSI Radeon 9600TX 128MB (basically a slightly o/c'd Radeon 9500pro), Seagate 120GB 7200rpm and I get an average of 28.3fps on those settings (taking an average of runs 2 and 3 on timedemo) and 35.7fps in Low.

I'm stumped, but I'm no expert. Have you tried a clean game install/latest drivers for all hardware?

EDIT: Heh, ok forget those times. I just ran some more tests having installed ATi's latest drivers and my system now gets 32.0fps average in HIGH. Massive improvement.

Do go to ati.com]ATi anyway because the latest drivers are bundled with catalyst control center, a simlar thing to nVidia's interface, and it's pretty decent.

Share this post


Link to post

Heh, I got fx5200 128mb, with 256 Rambus, and 2.4 Intel, I can run the game in high quality at 800x600, at roughly 25fps in fights.

Try disabling the nvidia program that runs in the taskbar. It takes up ALOT of memory only to do a AA and other effects. It usually made my games lose 10-20fps.

Share this post


Link to post

Thanks SmellyOgre,pritch.

SmellyOgre:Thats shocking! You've got the same config as I do and you are getting 25 FPS on high detail @ 800x600!
I disable the nvidia app that runs in the taskbar the moment I install a new release of the dirvers...and BTW,I dont use AA for any games...I guess my problem could be with the drivers...I currently have DirectX 9.0b and Forceware 56.72 for Win XP....I've just foundout that the latest versions are DirectX 9.0c and Forceware 61.77 for Win XP(I was slow) :) I havent downloaded the drivers yet..could they be the reason for my low framerates..I mean does the new 61.77 drivers improve the performance ?
Also,SmellyOgre,could you please post your timedemo (demo1) results ? Here are mine(with the old drivers) :
low(640x480) - 13.2
medium(640x480) - 10.3
high(640x480) - 9.3
high(800x600) - 6.2
high(1024x768) - 4.1

All Advaced setting except VSync and AA are turned ON.(Turning off the advanced settings didnt improve the framerate much either)

If the drivers are the culprits..then I'll download them right away..

Share this post


Link to post

get directx 9c and those latest drivers! Drivers sound well out of date.

And you've got an nVidia card. Heh, silly me blabbering on about catalyst.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×