Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Azreal_X

Oh, beans.

Recommended Posts

Alrighty alrighty. I have no idea what happened because I've made a few changes to my console and graphic settings, but it may have stemmed from my upgrading my nVIDIA drivers, as that's about when I started noticing it. "It" being that when imps or hellknights throw fireballs, and also when they began charging one up, my screen goes into a horrid flickering spell that is grating on my nerves. They throw the fireball, and the screen goes haywire, but also I've noticed that the smoke trail behind the fireball flickers too. I'm running at 800x600 @ 60hz (Quality mode, no AA, no AF) and am getting the feeling it has something to do with the post-process "heat haze" effect, but I absolutely know my FX5900 can do the effect, because it worked fine a few days ago. Other games run fine (I know I know, Doom3 isn't other games), and I've deleted the DoomConfig to reset it to defaults, so I don't think uninstalling the game would help anything. Anyone care to toss in their $0.02?

Share this post


Link to post

Alright. Well, about 2 mins after I made the post I found the culprit. It is the drivers. After turning on Vsync the problem dissappeared completely, but now if my FPS ever drops below 60 (even 59), my frame rate is automaticaly dropped to 30fps. Yes, I know you can get texture tearing without the game synced to your refresh, but nothing like THIS ever happened until I updated my drivers.

Anger... boiling...

Share this post


Link to post

Beans!

That is a weird problem. o_O What version of the drivers are you using? You could try the Omega drivers, they might fix it. (Someone else will need to link you, I forget where they are. Or you could google it.)

Share this post


Link to post

Well, I did try the omega drivers. They gave me a 10+ fps boost, but The flickering was worse. The current driverset I'm using is 61.77. It seems to work fine on 61.76, but the game's a bit too dark, and 61.77 runs a bit faster.

Share this post


Link to post

I've just recently discovered that the problem only affects fullscreen gameplay. If you window it, it works fine, albiet a few fps slower. Although it still runs faster than when I have it vsynced, this is really getting annoying.

Share this post


Link to post

I got curious and used the command "listrenderercmds" and found the command "gfxinfo"

When you type this it returns a few of the settings the engine is using on your card. For example I got this

Not forcing gl_finish
Not forcing swap interval
Vertex cache is fast
etc etc etc.

I knew my vertex cache was fast, I knew my swap interval wasn't forced (vsync), but I had no idea what gl_finish was, so I looked it up with "listcvars".

r_finish was set to 0 as the default. Not knowing what it was, I set it to 1. No more flickering. So if you want faster frame rates and don't care about the occasional texture tearing, you can now turn off that horrible vsync. Have a nice day.

Share this post


Link to post

r_finsih runs an extra pass or two over the frames to make them look nicer, iirc, so actually it would be running slower.

Nice that you fixed your problem though.

Share this post


Link to post

Faster, as in compared to vsync. I did notice it ran +15fps without it, but was unplayable due to flickering.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×