Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Need help with Wad Author...

Recommended Posts

I remember back in the good ol' days before Internet I was busy busy busy making wad's for Doom 2. I was like ten...

Now I wanted to get back into the picture (never did get the hang of Quake editing) so I downloaded Wad Author, and made a very very quick test map. I wanted to run it, but I get the error "error: could not change directory"

I have no flippin flappin' clue what the hell that means. I've read through the tutorials, help sections, and everything...I tried moving all the files from Wad Author into the Doom 2 directory, I've tried all kinds of junk...but I get this strange error.


Someone help me pleeaaase!

Share this post

Link to post

I believe you must first make sure you have Doom2 v1.9
Otherwise you won't get anywhere, period. You can download it.
Someone correct me if I'm wrong.

Share this post

Link to post

Surely you must be joking about downloading DooM2. Yes, the patch to upgrade it from v1.666 to v1.9 is free and downloadable, but otherwise the game is not legally downloadable for free.

Share this post

Link to post


Getting the 1.9 patch is always a good thing. :)

You *do not* have to have WA in the same dir as DOOM2. When you run WA for the first time it should have asked for you to pick a wcf ("wadauthor configuration file")...and I assume you choose DOOM2. Then it should have popped up something asking for the location of the DOOM2 iwad file. Clicking on the "Browse" you should have found your DOOM2 dir and then clicked on the DOOM2.wad (ex: "C:\Games\DOOM2"). Then, and only then, will WA allow you to create a map; you can't create a map if it doesn't know where to look for the things/flats/textures/etc. (re: the doom2.wad file), so I'm pretty damn sure you've gotten this far. ;)

Now, you've created a map. Preferably with 2 or more sectors (the BSP program in WA, and maybe others, doesn't really handle single-sector wads well). Now your problem. You are getting an error of it not being able to run, right? What you probably have to do is put the following lines into your wadauthor.ini file (find it in whatever dir you put wadauthor into; ex: "C:\WadAuthor"):


Save the changes. Now you should be able to run your map from whithin WA with no problems.


Paul L. Ming

Share this post

Link to post
This topic is now closed to further replies.
Sign in to follow this