Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Arioch

Doom 3 Linux Binaries Released

Recommended Posts

LinuxGames is reporting that the Doom 3 Linux binaries are out. Currently, id Software has put up a page for the files as well as a FAQ, which can be found here. Highlights:

  • Compatible with the win32 Doom 3 version 1.1, released earlier this week.
  • Only supported by NVidia graphics hardware/drivers as of now, ATI will at some point, eventually, release drivers that support Doom 3.
  • No amd64 builds at this time, though the statically linked binary ought to work on amd64 systems (Ed.: because NVidia provides a 32-bit compatibility interface in their drivers).
  • Localization not tested, probably best to avoid copying over the zpak000.pk4 file for now.
  • OSS API required for stereo sound, ALSA and 5.1 sound not supported yet. (Ed.: ouch)
  • If you happen to go outside, the oxygen meter gauge will remain displayed even after you get back inside.
  • Doom III would hang during starting if you redirect the output. Pass +set in_tty 0 on the command line to fix: $ doom3 +set in_tty 0 > output.txt

Of course, if you already have the win32 Doom 3, you could just copy over the pak files like the FAQ specifies and run the full game with the binaries, instead of downloading the demo.

The biggest thing for all of us to know out of all this is that Linux dedicated servers will be coming out of the woodwork.

Share this post


Link to post

Well, that sucks that ALSA isn't supported yet. I've been having problems getting OSS to work 100% correctly on my laptop.

Share this post


Link to post
Pate said:

ALSA has an OSS compatibility thingie. Have you tried using that?

Yes, but something screwy is still up with my sound. I can't have Gaim play sounds while XMMS is playing, and Quake 3 just never works. Then again, I never tried Quake3 when Gaim wasn't running, so it may be a mixing issue, or lack thereof. I have all my mixer and sound devices with mode 777, so I think it's a mixer configuration error on my part. But I'm too lazy to fix it yet.

I apparently lack hardware mixing.

Share this post


Link to post
DJ_Haruko said:

I can't have Gaim play sounds while XMMS is playing, and Quake 3 just never works.


That is because those programs grab the sound card all to themselves. OSS (and probably ALSA too) support only one user at the time. There should be a user space sound daemon like esd or arts that does the mixing. How this should be done has not been stardardised yet.

Share this post


Link to post

ESD and aRTs suck. They introduce gabs of lag and suck your CPU like no tomorrow. Just get a real sound card (and use the right ALSA driver.. not one that's "close enough").

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×