Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Nooooo.....my wad is screwed!

Recommended Posts

I have no idea what i have done to my wad. I might mess up with the lump b4. So now everytime I run the wad with doom2.exe, it occurs error: "W_CacheLumpNum: 3334 >= numlumps", could anyone tell me what I should do?

Share this post

Link to post

I remember having similar problems with my WADs. I think it was the PNAMES or the TEXTURE1 lump that was causing the problem. You can narrow it down like this: just rename those entries to something so that Doom doesn't recognize the lump (e.g. "PNAMES!" etc), then re-run the file. If the problem goes away, it is the entry you just renamed (took out) that has the problem.

You can email me (find address here: http://doomworld.com/xwe) your WAD and I could take a look if you like.

Share this post

Link to post

So now everytime I run the wad with doom2.exe, it occurs error: "W_CacheLumpNum: 3334 >= numlumps"

You have inserted flats and/or sprites in your wad. When you use the vanilla Doom2 engine you'll need to insert all other flats/sprites, too. For this you can use eg. deusf, available in our 'utilities' section. More information in the docs.

If you want to use a port to run your wad, make sure you have inserted your flats and/or sprites between the appropriate entry markers. See the documentation of your source port for more information.

Some tips on inserting extra flats/sprites in your wad for vanilla Doom can be found at Doomworld's Editing Tutorials.

Hope this helps,

Share this post

Link to post

"W_CacheLumpNum: 3334 >= numlumps", could anyone tell me what I should do?

Technically it means that a lump index value was passed that did not exist in the list of names that were cached. IOW 3334 is greater than the number of lumps cached.

As already noted, it can be anything that relies on "control" markers to designate the group or is set in the TEXTUREx/PNAMES control lumps. The latter would be caused by an invalid index value in TEXTUREx.

To check on a TEXTURE problem you can load the level in DeePsea (current version is 11.2), press F7, select Texture Edit.

Click on the "Verify GRAPHICS" to see if any patches are missing from PNAMES. (Also verifies patches cover the texture).

Click on "Verify PNAMES" and it checks to make sure all your texture graphic lumps exist.

If it passes those then it's likely to be one of the other ones already mentioned. IIRC, usually bad graphic stuff shows up as a w_getnumname error if a lump is missing or it catches it in basic control loading.

p.s. Technically a level that is "missing" control information can also get that error message.

Share this post

Link to post

If anyone is curious - 999cop sent me the level (sort of a surprise - but a nice one).

It was an F_START in the PWAD which made the flat calculations start with this PWAD.

Didn't have much chance to play it, however, what I played was interesting:)

Share this post

Link to post
This topic is now closed to further replies.
Sign in to follow this