Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
funduke

Request for Downgrade patch for Heretic and doom2

Recommended Posts

Is there a downgrade patch that downgrades Heretic v. 1.3 to 1.2 or lower?
If not, can anybody create and release such a downgrade patch?

A downgrade for doom2 would be also nice.

I have very good experiences with that downgrade patch, that downgrades Ultimate doom to the lowest registered version. I made the downgrade and then all the upgrades in different directories. So i have no longer any problems with Dehacked-patches and demo-lmp's for older versions of doom.

To have that for heretic and doom2 would be cool.


Greetings
Funduke

Share this post


Link to post
funduke said:

Is there a downgrade patch that downgrades Heretic v. 1.3 to 1.2 or lower?


O.K., for Heretic, idid it on my own:

ftp://3darchives.in-span.net/pub/idgames/utils/exe_edit/herdwngr.zip
ftp://3darchives.in-span.net/pub/idgames/utils/exe_edit/herdwngr.txt

This is, what the textfile says:

===========================================================================
Downgrade to : HERETIC v. 1.3
Primary purpose : No levels included
===========================================================================
Title : HERETIC downgrade patch v. 1.3 --> 1.0
Filename : herdwngr.zip
Release date : 06. November 2004
Author : Funduke
Email Address : funduke@hotmail.com
Misc. Author Info : I love Duke3d, DooM and, of course, HERETIC :)

Description : This patch downgrades HERETIC v. 1.3 (HERETIC,
SHADOW OF THE SERPENT RIDERS) to v. 1.0 of
HERETIC.
That's helpful for exe-hackers, users of
heretic-deh-patches, created with older versions,
fans of demo-lmps, recorded with older versions,
and because of nostalgia.


Additional Credits to : Raven software and id software

Other files required : Fresh installation of HERETIC v. 1.3
If you only have v. 1.2 of Heretic, and want to
downgrade to 1.0, you must first upgrade to v.
1.3, befor you can use this downgrade.
Yo can get the upgrade from 1.2 to 1.3 for
example here:
ftp://3darchives.in-span.net/pub/idgames/idstuff/heretic/htic13rp.exe
If that URL doesn't work, use any search-engine,
for example google, to look out for the file
htic13rp.exe .

The update patch, that updates your fresh-made
v. 1.0 to 1.2, can be downloaded for example
here:
ftp://3darchives.in-span.net/pub/idgames/idstuff/heretic/10_12rhp.exe
... and here's the readme-file:
ftp://3darchives.in-span.net/pub/idgames/idstuff/heretic/10_12rhp.txt

* Play Information *

Game : Heretic


* Copyright / Permissions *

You MAY distribute this file, provided you include this text file, with
no modifications. You may distribute this file in any electronic
format (BBS, Diskette, CD, etc) as long as you include this file
intact.

* Where to get the file that this text file describes *

The Usual: ftp://archives.3dgamers.com/pub/idgames/ and mirrors


Greetings
Funduke

Share this post


Link to post

Dehacked/HHE and other compatibilities. Seeing older verions of levels (for example Doom 2 map02 before they removed some bars by the beginning switches, Doom 2 map 17 with a seethru wall), getting other old wad resources, having a version before new problems were added. It's just plain interesting to have official versions of the games with substantial differences.

Share this post


Link to post

Grr... Lucky bastard, able to run the DOS .EXEs... Oh well, Zdoom works well, just sometimes have nostalgia for my old 486 that I first played Doom on. Those were the good ol' days... BLEEP BLEEP BLOOP BADADADADADA (Couldn't really think of a good way to represent the gibbing sound effect on the PC speaker). Now there's a project somebody needs to do - make a PC speaker resource wad for people who want to play Doom old school but can't. Gosh I miss those old sound effects.

Share this post


Link to post
geekmarine said:

BLEEP BLEEP BLOOP BADADADADADA (Couldn't really think of a good way to represent the gibbing sound effect on the PC speaker). Now there's a project somebody needs to do - make a PC speaker resource wad for people who want to play Doom old school but can't. Gosh I miss those old sound effects.

http://dosbox.sourceforge.net
Check out Dosbox.
I haven't tried it yet with doom, but had nice results of PC Speaker emulation with duke nukem I + II.

Greetings
Funduke

Share this post


Link to post
Gokuma said:

Or get rid of XP.

Bad idea. '98 is no longer supported by Microsoft. And the damn OS gave me nothing but grief. :/

Share this post


Link to post

I think support for win98 is extended until January '05 or so. At least when I was looking at fdisk.exe limitations, the KB article is still accesible on microsoft's site, and you can still download the fixed version.

Heck, I even found some KB articles for win95.

EDIT: By January I actually meant June :) Anyway, seems I still wasn't correct.

Share this post


Link to post
funduke said:

http://dosbox.sourceforge.net
Check out Dosbox.
I haven't tried it yet with doom, but had nice results of PC Speaker emulation with duke nukem I + II.

Greetings
Funduke


O.K.. i tried it now with the emulator.
DosBox did the job. It uses the soundcard as output device for the sounds that have been intended by the doom-creators for the PCSpeaker.
Here's the command, cut and pasted from my shortcut:

C:\Programme\DOSBox-0.61\dosbox.exe -conf "C:\Programme\DOSBox-0.61\dosbox.conf" F:\DM2_1666\doom2.exe -c

You should be able to find the way how to to it.
The only bad thing is a big noticeable slowdown of the game, because it has to share the power of my computer with the emulator. I set the graphics quality of the game on 'low' and the screen size on the minimum and it does play.
I have a Pentium III, 700 Mhz, 128 RAM. If your computer has much more power, you will have much less slowdown.

Greetings
FunDuke

P.S.: Just in case: Of course you have to tell the game before you start by using setup.exe, that you want to use the pcspeaker.

Share this post


Link to post

Gokuma said:
Regular 98 is glitchy as hell

It is? How? That was likely your machine, the lack of updates, or your setup.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×