Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Quasar

Eternity Engine v3.31 Delta Prealpha 2

Recommended Posts

The new pre-release alpha of the final 3.31 build of Eternity will be released tonight when I get off work. All that's left to do is upload it and update the Eternity page. I'll post in this thread as soon as the release is complete.

Share this post


Link to post

The alpha is in case ANOTHER major issue is found. After all this time, I want 3.31 final to be the real deal. If no major issues are found within a couple days' time, I will release 3.31 final, along with the Small compiler distribution for EE.

There are also a couple of minor things I want to get done during that couple of days' time, like renaming all the Small native functions *again* to use a consistent EE_ or ee_ prefix instead of a multitude of different prefixes. This'll make the names easier to remember than they currently are and will free up a considerable amount of namespace for use by script programmers.

Share this post


Link to post

Cool, well I've run all of Millennium's Eternity-specific stuff through testing and it all works good as ever. I haven't been making huge attempts to break anything though. What I have been doing is learning portals - I was surprised how quickly I picked it up (hey look, somebody who reads the docs for once) and can't stop putting them everywhere :D

One thing that does irk me and also exists in beta 7 doesn't actually have to do with anything in-game. Rather, it's what I find done to my desktop when I quit. There seems to be a randomized process which decides whether or not Etenity will take every open window and scrunch it into the upper left corner of my desktop. This is done relative to the resolution I was playing in. For example, I typically play in 640x400, so when I quit I might find all my open windows resized to fit in a 640x400 desktop and piled into the upper left corner of the screen. For a non-resizable program like WinTex, the bottom or side of the window will be removed completely and I can only get them back by closing and restarting the program.

Sometimes it happens after a few seconds of playing, sometimes it happens after a few hours. Sometimes it happens without completing a single map, sometimes it happens after completing 20. Sometimes it happens with 2 windows open, sometimes it happens with 20 windows open. Sometimes it happens in 320x200, sometimes it happens in 640x400. I can't find a shred of consistency for why this happens. But it does, so hopefully there's a quick fix you can find.

Share this post


Link to post
Lüt said:

Sometimes it happens after a few seconds of playing, sometimes it happens after a few hours. Sometimes it happens without completing a single map, sometimes it happens after completing 20. Sometimes it happens with 2 windows open, sometimes it happens with 20 windows open. Sometimes it happens in 320x200, sometimes it happens in 640x400. I can't find a shred of consistency for why this happens. But it does, so hopefully there's a quick fix you can find.

The inconsistency is because Eternity itself is not responsible for this behavior. This is a bug in either DirectX or (much more likely) SDL. You might wanna report it to the SDL guys; I have seen this happen too but I can assure you there's nothing in *our* code that would make it happen. Some of my other SDL-based programs also cause this on occasion.

Share this post


Link to post
Quasar said:

The inconsistency is because Eternity itself is not responsible for this behavior. This is a bug in either DirectX or (much more likely) SDL. You might wanna report it to the SDL guys; I have seen this happen too but I can assure you there's nothing in *our* code that would make it happen. Some of my other SDL-based programs also cause this on occasion.

Ah, I see. Bummer.

Now that you mention it, I do remember this happening on occasion with certain other programs as well. Would I be correct in assuming you're given actual editable code by the SDL guys? Is this anything you could look at regardless of whether you wrote the code or not, or is it just too complex to even bother looking at? I doubt it's a DirectX issue because, well, it's never happened with other strictly DirectX-based fullscreen games I've run, ever.

BTW this is their site, right?

Share this post


Link to post

That map was great for showing off the portals. I'm eagarly looking forward to see what people produce using small.

I really like Eternity, it feels like Doom unlike Zdoom which IMO has butchered the control mechanisms.

Two requests:
Can you increase the range on the mouse sensitivity sliders? Even at full it's not as responsive as I'd like.

All monsters still have the infinite height attacking. Which makes it difficult to cross areas with bridges like in OGRO when there is a monster attacking you from beneath. Sorry if this is already included but I couldn't find it on the menu.

Share this post


Link to post
DaniJ said:

All monsters still have the infinite height attacking. Which makes it difficult to cross areas with bridges like in OGRO when there is a monster attacking you from beneath. Sorry if this is already included but I couldn't find it on the menu.

Interesting, I haven't had that issue since Beta 7, which IIRC is when z-clipping was implemented (I jumped from Beta 3 to Beta 7, so I may have missed something). I just tried walking across some monsters by jumping on them from a high ledge and it worked fine.

Share this post


Link to post

Hmm that is odd.

I'll replay OGRO again and see if I can recreate it but the first time around it was definetly an issue.

The area inside the mountain where you have the room with a bridge right in the middle leading upto where the red skullkey is. I ran up there then when I came out there was pinkys running around and I couldn't get back across the bridge because the pinky below me (under the bridge) was attacking.

Share this post


Link to post

Sorry for not responding earlier. Real Life stuffage, and all.

Did some initial runs with the latest version. Results:

Monsters do not move on 3DMidTex lines. They refuse to step on them, and once placed on a 3DMidTex line they still don't move and don't even react to the player. Am I missing something? [EDIT] I see they do move on one of the bridges in SoM's level. I'll try and see what causes this.

The portal problems I experienced earlier are gone.

Needs more testing of course, but it looks like I won't have much time for that atm. If you need me to whip up a small test level, just say so. Response time may vary ;)

Share this post


Link to post

Both my own test maps and the test map you sent me work perfectly with the new 3DMidTex clipping code. Maybe you aren't using the lines in a way that monsters can walk on them? The lines must be close enough that a monster's radius can extend onto them while they are still standing on solid ground or else they will not walk onto them. Also, an area between two 3DMidTex lines that have the monster blocking property must be at least as wide as 2x the monster's radius + 1 unit, because as far as the monster is concerned, those lines are solid as a rock and cannot be moved through. I know you like to make some razor-thin structures.

Oh, and also, the new clipping code forbids ALL moves that result in a height difference greater than 24 units when a monster is on 3DMidTex lines. So they cannot step up or down 3DMidTex "stairs" that are higher than 24, which is also the limit for normal movement, certainly by no coincidence.

Share this post


Link to post

Funny, because that testmap was just a copied & pasted bit from a real map :)

I'm not much online these days, as I have some sort of crisis on my hands here. Will keep you guys posted though!

Share this post


Link to post

Please let me know what's up or provide non-working example maps as soon as you possibly can, so that I can move forward with development. I'm kind of waiting right now to see what's up with this, as I'm tired of dealing with it being broken >_<

Share this post


Link to post

Well, that took me long :/

The testcase level I posted earlier (Imp on crossbeam; alpha.wad) does not work either. I don't think I changed settings. Could you post your settings, so I can compare?

After some experiments I still do not know what is causing problems. Sometimes, 3DMT bridges behave as they should (SoM's level, my own level) but other bridges in the same level don't. Sometimes monsters walk over a bridge up to a certain point, but refuse to go over some "invisible barrier"... maybe a change in floor height above which that bridge is suspended? Other monsters which are lowered on a 3DMT line just become stuck and won't react to the player at all.

I tried to increase/decrease the distances between 3DMT lines (16-24-32), and different types of construction. It does not seem to make a difference.

In short, I'm a bit baffled.

Share this post


Link to post

Monsters ignore all normal dropoffs when standing over 3DMidTex lines. I cannot recreate any of these problems. Are you sure you are using the newest alpha? If so, then I'm afraid this problem may simply be unfixable. I've already tried everything in the book.

Also remember that 3D thing clipping is completely separate. Do you have it turned on or off? If it is off, monsters on 3DMidTex lines cannot walk over monsters or other objects that are below them. This cannot be enabled separately.

Share this post


Link to post
DaniJ said:

I really like Eternity, it feels like Doom unlike Zdoom which IMO has butchered the control mechanisms.


Hmm, in what way? I only ask, because I've never really been able to tell the difference in any Doom ports controls really. Not even Vavoom, which some people will swear feels horrible.

Share this post


Link to post

Hmm, in what way? I only ask, because I've never really been able to tell the difference in any Doom ports controls really. Not even Vavoom, which some people will swear feels horrible.

To me Zdoom feels unresponsive and "loose". There is too much momentum and I just don't like the feel of the mouse. I've pretty much stopped playing Zdoom now because of it unless there is no other port that I can play a certain wad in.

When playing Eternity the control feedback and response feels almost exactly the same as it did when I first played Doom.

I agree about Vavoom, it feels (and looks) like Quake. I don't play much Vavoom...

Some people notice things like controls more than others I guess.

Share this post


Link to post

For me it's the other way around; I find ZDoom's control feels more natural than that of any other port.

It's hardly a matter of "noticing more", rather a matter of what you're used to.

Share this post


Link to post

Scratch that, I just played doom2.exe and ZDoom's mouse feels a lot closer than Boom or Eternity.

I dunno, maybe it's driver-related?

Share this post


Link to post
Fredrik said:

maybe it's driver-related?

Almost certainly.

For me, mouse control in Eternity and GLBoom is pretty similar to Doom2.exe. Other than at start-up, I don't perceive any major difference, and can switch between them fairly easily. BTW, I have sensitivity set pretty high (around 50).

Share this post


Link to post

Eternity's mouse control works just how I want it to. ZDoom's lags quite a bit for me and is just generally jerky and annoying.

Share this post


Link to post

The way things feel to me, moving the mouse slowly makes the player turn too slowly and moving the mouse quickly makes the player turn too quickly. Changing the sensitivity makes one better and the other worse, and "smooth turning" doesn't make much of a difference at all.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×