Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Bug with exporting multiple WAVESOUND lumps

Recommended Posts

With the latest version (and it's been doing this since 1.12), I can try to export multiple Wavesoud lumps at once, and randomly it will just take the first one I clicked on and duplicate it with the names of all the ones selected. So for example, if I were to click on DSCHNGUN and then Shift-click on DSBARON, highlighting all the way down and selecting DSSARGA, DSFANG, and DSTHINGY along the way, then go Entry -> Save as, it would extract all of these files, except they'd all sound exactly like DSCHNGUN. I have no clue what causes this, and it only does it with sounds (I don't know if it does it with OGG/FLAC or not).

Share this post

Link to post

You are correct, this is in fact a bug. Thanks for pointing it out.

I will fix it as soon as I can.

There are two ways to work around it until then: either save them individually, or click Entry|View raw data. That way they will be exported "as is" - without any conversion, just the lumps. (E.g. if they were Doom format sounds, you won't be able to play them from Windows, but you can still import them into any WAD and they will work fine.)

Share this post

Link to post


if you were to export the sound lumps as raw data, I've found that Goldwave can actually open the sounds and play them perfectly (you need to specify the correct sound settings though, aswell as open them as a raw sound file)

Share this post

Link to post

Yes, you can open the doom wave format file in any decent WAVE editor, because they are almost RAW format.

Except that there are 8 bytes of header at the beginning of the file ($0003 - which is a fixed id, sample rate and data length). Those 8 bytes will produce a very short noise or click. If you want to edit them properly, cut off the first 8 bytes in a hex editor (or simply export them from XWE as a WAV and save all the trouble, it does work fine if you use the export individually).

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this