Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
entryway

PrBoom-Plus, ver. 2.5.1.4

Recommended Posts

I had it on DOSDOOM comp level, I thought that would be fine.  I switched it to ULTIMATE DOOM and I was able to go through.

 

 

 

Edited by vanilla_d00m

Share this post


Link to post

I have encountered a strange glitch in PrBoom+ 2.5.1.4 where when I watch back demos for some reason all the sound except the game music isn’t played and my controls like pausing the game or stopping the demo are locked and I have to alt F4 to exit or I can click my mouse and that seems to fix the game sounds and demo controls. I haven’t had this problem until recently.

Share this post


Link to post

As far as I am aware (that is, after testing playback of all available Dosdoom .47 demos), the only difference between complevels 3 and 5 occurs if there is a spechits overflow. All available demos recorded with Doosdoom .47 play back OK when -complevel 5 is forced, and all without overflows play back OK when -complevel 3 is forced.

 

more info

 

Sector 147: That sounds like something that can happen if two instances of the program have been started.

 

On the subject of using complevels for general play (as opposed to recording or playback), I shall quote myself, as I suspect this point is not widely known:

Quote

If you're just playing normally or practicing stuff, then the simplest way to make sure of getting -complevel 2 behaviour (or any other complevel) is to set it via the "default compatibility level" in the in-game menus.


OPTIONS -> GENERAL -> (second page) -> DEFAULT COMPATIBILITY LEVEL

Set it to "DOOM/2 V1.9"


Then exit the program and restart.


It will then apply -complevel 2 behaviour every time you run Prboom+ until you change this setting and unless you override it from the command line or by playing back a demo.

If you only set the complevel from the command line, then I don't think it preserves that setting upon loading a save or if you start a new game, etc. The distinction doesn't matter so much if you are recording a demo, since if you fail you'll just restart the program in any case. But for casual play or practice, it makes a difference.

Remember that as long as you have this setting, it will always try to play maps as if you are using Doom2.exe. So Boom maps won't work right, and Ultimate Doom won't have episode 4 and there will be a few more subtle differences too. Any individual compatibility settings will also be ignored.

Edited by Grazza

Share this post


Link to post

Why does GLBoom+ have a nice textured automap but not PRBoom+? Is there some kind of technical limitation in Software mode?

Share this post


Link to post
26 minutes ago, Spectre01 said:

Why does GLBoom+ have a nice textured automap but not PRBoom+? Is there some kind of technical limitation in Software mode?

There's nothing pre-existing in Doom's renderer for it, no.

Share this post


Link to post
1 hour ago, Spectre01 said:

Why does GLBoom+ have a nice textured automap but not PRBoom+? Is there some kind of technical limitation in Software mode?

 

I suspect that textured automap need GL-Nodes.

Share this post


Link to post
9 minutes ago, Josuke said:

I know this has been answered quite a bit, but how do I load pwads?

 

With a command line argument, the easiest way.

 

Ex: -iwad doom2.wad -file av.wad.

Share this post


Link to post
10 minutes ago, seed said:

 

With a command line argument, the easiest way.

 

Ex: -iwad doom2.wad -file av.wad.

I dragged it over the exe and it loaded, so new question I guess: how do I remove keybinds?

Share this post


Link to post
2 minutes ago, Josuke said:

I dragged it over the exe and it loaded, so new question I guess: how do I remove keybinds?

You can't remove keybinds in 2.5.1.4. You can in the newest beta, though.

Share this post


Link to post
1 hour ago, Josuke said:

Not even via config file? (also, gonna need the link to said beta)

 

I'm pretty sure you can via config file -- just erase whatever is next to the action. It will read "junk" in the menus. I think I did this to unbind the weapon scrolling via mouse wheel.

 

@lazy91geek is likely referring to the 2.5.1.5 "test" version. A download link is at the top of this page: http://prboom-plus.sourceforge.net/history.html

Share this post


Link to post

Is there anyway to prevent a wad from altering the menu? In Eviternity, selected options are no longer highlighted, which is annoying when trying to adjust settings quickly. I'm also having some serious framerate issues(Linux, nvidia, good pc, capped framerate: off, vsync: off) compared to other source ports, but I'm probably just setting things up wrong.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×