PrBoom-Plus, ver. 2.5.1.4

When you play back a demo, you need to load the same wads (iwads and pwads) that were used when recording it.

There are various ways to achieve this.

You can turn on extended format when recording, so that the wad info is recorded in with the demo.

Alternatively, you can use standard naming so that the demo name is recognized by autoloading (which you need to have turned on). If the wad is not one that is included in the autoloading patterns, you can add it yourself, if you know what you are doing.

Or you can load the wads via the built-in launcher, if you have it enabled.

And finally, you can load them the old-fashioned way, via the command line. To specify an iwad, you need to use, e.g., -iwad doom.wad

Obviously all the wads need to be somewhere that they program will find them. That would be in the same wad as the exe, the current directory, or the $doomwaddir$.

BTW, I strongly recommend not using a new directory each new version. It's messy and error-prone. Just overwrite the old version of prboom-plus exes with the new one, but keep your old cfgs.

Share this post


Link to post

Solved the problem. The in-game launcher was set to smart, but "smart" recognized the wrong wads, since extended format wasn't turned on when recording.

Looks like people who are using this version should set it to "always" instead of "smart." Never had this problem before.

Share this post


Link to post

My problem is also solved, thx a lot.

I just got 5 mpas of ultimate doom havn't record, I will try to finish it after some pratice if I have time.

Share this post


Link to post
RjY said:

in the next build you should be able to put "mouseb_use 2" and "mouseb_forward -1" in your prboom-plus.cfg.


Soon it will finally work for my linux install and my wife's Mac so I just wanted to say... Thank You! :D

Share this post


Link to post

Hey guys I've been having a strange problem with PrBoom+ for a while now. First off I really enjoy it, it seems to render huge levels for me without any lost of frame rate and I love being able to watch demos, however every so often it becomes choppy and slows down for a split second, especially when I open doors or encounter a bunch of enemies at once. Again this doesn't always happen, sometimes I play it and there isn't any slow down at all.

I've tried a number of things, the frame rate is capped, I changed the sdl_videodrive to directx (stopped the vertical tearing), changed the renderer to speed and tried using Timidity. Nothing has worked.

Any ideas guys?

P.S. Using Windows XP SP3, 2GB Ram, ATI Xpress 1150 graphics card.

P.S.S Using PrBoom+ 2.5.0.8 but had same problem in 2.5.0.7

Share this post


Link to post

Yes that is the setting, in my config file.

EDIT: Just changed it to zero but I seem to be having the same problem.

Share this post


Link to post
Chex Warrior said:

Yes that is the setting, in my config file.

EDIT: Just changed it to zero but I seem to be having the same problem.

Should be 1. Have no ideas then.

Share this post


Link to post
RjY said:

in the next build you should be able to put "mouseb_use 2" and "mouseb_forward -1" in your prboom-plus.cfg.


Many thanks for this. It was long overdue. Works great in prboom-plus 2.5.0.9 test ... :)

Share this post


Link to post

I've moved some internal automap variables to config and now you can have something like that (map_overlay_pos_x/y/width/height and map_textured(lines)_overlay_trans config variables):

Share this post


Link to post

Thats awesome! I assume the iddt cheat still works with the map overlay correct!

(Don't answer I'll find out myself)

This feature is a great way to plan out routes!

Share this post


Link to post

They say that Macs are easy to use, but I call bullshit on that. Can someone tell me how to get this running on one? Please give me the extreme basics.

Share this post


Link to post

Oh lord how do I check

Share this post


Link to post

Apple > About this Mac

For PRboom+ to work (I assume you've been able to install the actual app) you need to put your iwads in this folder:


(Cmd shift g) then type this:
~/Library/Application Support/PrBoom-Plus

Then you should be able to play.

Share this post


Link to post
Mr. T said:

Apple > About this Mac


Thank you. It's running 10.5.8.

Mr. T said:

For PRboom+ to work (I assume you've been able to install the actual app) you need to put your iwads in this folder:


(Cmd shift g) then type this:
~/Library/Application Support/PrBoom-Plus


I downloaded the PrBoom-Plus-2.5.0.8.dmg from here, mounted the disk image, opened it up, and dragged PrBoom-Plus into the applications folder. I figured I was supposed to put the IWADs in "~/Library/Application Support/PrBoom-Plus" because I found similar instructions online for installing regular PrBoom on a Mac.

Mr. T said:

Then you should be able to play.


"The application PrBoom-Plus quit unexpectedly."

Process:         Launcher [94318]
Path:            /Applications/PrBoom-Plus.app/Contents/MacOS/Launcher
Identifier:      net.sourceforge.prboom-plus
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [82]

Interval Since Last Report:          476 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2010-12-13 23:01:15.637 -0600
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  A936E792-8A38-45C3-B8B4-149F34B70CBC

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  unknown required load command 0x80000022

Share this post


Link to post

Generally a break point exception in the release version of a program would be indicative of stack corruption, ie., the return address was overwritten and the IP jumped into a non-code area.

Share this post


Link to post

PrBoom-Plus-2.5.0.8.dmg is for 10.6 only. That's because it crashes. Try PrBoomPlus2508OSX104u.dmg.

Share this post


Link to post

If your Mac isn't terminally old (pre-2006) you could, no SHOULD just install 10.6 (Snow Leopard.) It's basically a service pack that you have to pay $teve Job$$$ $30 for.

Of course, no Apple-released software has copy protection of any kind, so... *shifty eyes*

Share this post


Link to post
Mr. T said:

It's basically a service pack that you have to pay $teve Job$$$ $30 for.


HAHAHA seriously? Come on, Apple.

Share this post


Link to post
entryway said:

Try PrBoomPlus2508OSX104u.dmg.


Thanks, it's working! Just one more question: is there a way I can get PrBoom-Plus to start with the launcher every time instead of directly entering into the game?

Off topic: I always thought that Apple haters were extremists, overreacting to the fact that Apple isn't exactly like Windows. Well, that may be the case, but it only took me about five minutes in the Apple forums for me to feel a pure and malevolent hatred for Apple, Apple zealots, Apple products, Apple employees, Apple philosophies, and everything else that Apple stands for in this and all other possible worlds.

Share this post


Link to post
Creaphis said:

Thanks, it's working! Just one more question: is there a way I can get PrBoom-Plus to start with the launcher every time instead of directly entering into the game?

I do not know about that launcher. Even did not see it.

Share this post


Link to post
entryway said:

I do not know about that launcher. Even did not see it.


Interesting. The first time I started PrBoom+ on here it gave me a launcher, which I liked as it even had a few more features than the one I'm used to seeing on Windows. It might have only come up because PrBoom+ hadn't auto-detected any IWADS, or because there was no .cfg file yet.

Share this post


Link to post

There is a way to fire it up WITHOUT the launcher? :O

Don't be disheartened about Macs. The forums are full of retards and people who give nothing but stupid cookie cutter answers, but there is a lot of good information out there on blogs.

Macs are good computers for work. The OS is about 100x better than Wind0ze

Share this post


Link to post

Okay, I've got another question (though it might be more of a question about Macs than about this source port): how do I pass command line arguments to PrBoom+ when using a Mac?

EDIT: Okay, I did some digging and now know a lot more about the Unix terminal than I did before. Unfortunately, since I'm not running OS X 10.6 (and since it's not my place to upgrade somebody else's computer) I can't pass command line arguments to PrBoom-plus with the "open" command, and when I execute the PrBoom-plus executable directly it fails to find prboom-plus.wad. To get this to work I'd have to learn some really disgusting work-arounds and I'm not interested in doing so right now.

"It just doesn't work."
--Creaphis

Share this post


Link to post
Mr. T said:

There is a way to fire it up WITHOUT the launcher? :O

Esc>Options>General>2nd page>"Use in-game launcher" set to never.

Is this what you are talking about?

Share this post


Link to post

My copy of PrBoom-Plus 2.5.0.8 "OSX104u" doesn't have that option.

Share this post


Link to post

The missed backside overflow emulation appears to have fixed the desync in xm22-621.lmp in my set of demos on H2H-Xmas. (This demo, recorded with Prboom, doesn't play back with Doom2.exe. With the emulation turned on, it now desyncs "correctly" in Prboom+.)

Share this post


Link to post

entryway, do you have a copy of the WAD that was on your GeoCities site before it was taken down?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now