Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
AliensTC4Eva

How to get Aliens T.C. to work properly in Doom2 version 1.9

Recommended Posts

I have the file doom2atc.zip from this site: http://www.gamers.org/pub/games/idgames/themes/aliens/ but I realize that this version of Aliens TC for Doom 2 was only available/only works properly for Doom 2 version 1.666. I don't have version 1.666. I've tried looking everywhere for a fix or a patch but nothing. I found a page related to this matter at this site: "http://www.geocities.com/Hollywood/5422/alienstc.htm".

The T.C. will run but everything is completely wrong (as in look and feel compared to the Aliens T.C. for Doom 1/Ultimate Doom)for some reason.

Anyone have any ideas???

Share this post


Link to post

You can use this to create a v1.666 copy of DOOM II.

Share this post


Link to post

the version of doom should not make a difference in how it looks or plays

it should work just fine with version 1.9

Share this post


Link to post

IIRC Quasar made a one-file ATC version that works with all (Boom-compatible?) source ports. It used to be linked on the Eternity page (again, IIRC), but it doesn't seem to be there anymore.

Share this post


Link to post

perhaps he's played it before on another computer, and his computer has a different version of doom. that would be the most logical answer.

Share this post


Link to post
boris said:

IIRC Quasar made a one-file ATC version that works with all (Boom-compatible?) source ports. It used to be linked on the Eternity page (again, IIRC), but it doesn't seem to be there anymore.


http://arach.net.au/~locust/sw/atc/

It's not linked on his Eternity page for some reason...

Share this post


Link to post
Xtife said:

the version of doom should not make a difference in how it looks or plays

it should work just fine with version 1.9

Sorry, but no. Any Doom (2) add-on which makes use of a DeHackEd patch (as Aliens TC does) is version specific. It is possible to alter the .deh file to make it compatible with a different version, but that requires technical know-how.

Share this post


Link to post

Don't use Zdoom. Zdoom does not work correctly with most versions Of Aliens Doom. Try using PrBoom instead.

Share this post


Link to post

@myk

thanks for the patch. Although that seems like it's one solution. Is there any other way to get the "Doom 2 version" of Aliens T.C. to work properly on Doom 2 version 1.9 and all the other Source ports for 1.9 versions of Doom/U-Doom/Doom 2, such as Boom, Z-Doom, Legacy, etc. due to the .deh file in doom2atc.zip was originally written for Doom 2 version 1.666? Anyone have any other ideas besides myk's downgrade patch?

@myk

thanks for the patch. Although that seems like it's one solution. Is there any other way to get the "Doom 2 version" of Aliens T.C. to work properly on Doom 2 version 1.9 and all the other Source ports for 1.9 versions of Doom/U-Doom/Doom 2, such as Boom, Z-Doom, Legacy, etc. due to the .deh file in doom2atc.zip was originally written for Doom 2 version 1.666? Anyone have any other ideas besides myk's downgrade patch?

@deathbringer

If I had not played Aliens T.C. before how would I be able to compare, and figure out what was wrong with the Doom 2 version? I've use the Ultimate Doom version, which I believe is these two files that I've downloaded a long time ago:

http://www.gamers.org/pub/games/idgames/themes/aliens/u_alntc1.zip
http://www.gamers.org/pub/games/idgames/themes/aliens/u_alntc2.zip

Anyways check this file out if most or any of you are still confused as what I am talking about.

http://www.gamers.org/pub/games/idgames/themes/aliens/doom2atc.txt

Now, only if someone knows how to convert a DeHacked file written for Doom 2 version 1.666 to Doom 2 version 1.9 then I guess my problems would be fully solved.

Share this post


Link to post
NiGHTMARE said:

Check out the link david_a provided.


That patch is not for Doom 2 version of Aliens T.C., only Ultimate Doom's version, and I have no problems running Aliens T.C. on Ultimate Doom.

Share this post


Link to post

With a bit of minor editing, you should be able to use the .deh patch from it with the Doom 2 version of Aliens TC.

All you should really need to do (I think) is change "Doom version" from 21 to 14. You may also want to change the E2Mx references to MAPxx, else the new level names won't appear on the automap.

Share this post


Link to post

Is there supposed to be monsters in this TC or not. The whole first level had no monsters. At the end, it said 0% kills.

I'm using the latest PRBOOM with DOOM 2 1.9 with the special deh file provided in the post just above mine.

Lastly, I have to go outside the game to turn the music down, on any level, since the ingame music adjuster is busted (this is also PRBOOM).

So how many levels do I go thru w/o monsters?

Share this post


Link to post

So far only the downgrade patch from 1.9 to 1.666 seems to be the only solution, no luck with loading the "atc2.deh" file into dehacked for version 1.9 It still has the same problems, I.E. on the first level of Aliens T.C. for Doom 2, the Eye in the Middle of some Green Object is still there instead of the new Gray Antenna Post looking object. Not to mention that there is no Alien Queen, but instead you will find a Spider Mastermind stuck in a cramped spot blinking, appearing and dissappaering. Everything looks completely ****** up!

There can only be one other solution I can think of right now and that is if anyone knows how the person who converted Justin Fisher's Aliens TC wad and deh files for use with Doom 2, and what tools and utilities he used to convert them with.

Then maybe it's possible to start from sratch and convert those files to work properly with Doom 2 1.9

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×