Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Apothem

Sethudsize is not working ....

Recommended Posts

No matter what i set the coords to the hudmessage command to, it only displays the gfx in the upper left corner.

#include "zcommon.acs" 

Script 1 ENTER 
{ 
sethudsize(800,600,1); 
setfont("regular"); 
hudmessage(s:"a"; 1, 1, CR_GREEN, 100, 10, 1); 
delay(2); 
restart; 
} 

Share this post


Link to post

Read the Wiki entry for SetHudSize again. There it says:

After using sethudsize, hudmessage coordinates also behave differently. You now need to specify actual pixel coordinates and not numbers in the [0.0, 1.0] range. However, they are still fixed point, so you need to keep the decimal point. e.g. If you used SetHudSize (320, 200, 1); and want to draw a hudmessage at the center of the screen, you should pass it the coordinates (160.0, 100.0) and not (0.5, 0.5).

The fractional part of the coordinates effect what part of the hud message you are positioning: For x: .0 = positions center of box .1 = positions left edge of box .2 = positions right edge of box .4 = centers text inside box .4 can also be added to either .1 or .2 to get .5 or .6

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×