Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Upgrade patches?

Recommended Posts

For some reason, I'm having zero luck finding the latest patch for Doom 3 or RoE. I've uninstalled and reinstalled both games and I still get an error for RoE that essentially says there's a problem with loading the double barrel shotgun (the game does not entirely initialize) information. I figure that this could be solved with some uprgrading, which leads me to my dilemma. Do you know of any places I can grab them?

Share this post

Link to post

I'll post the error message when I get my computer connected with the internet again. In the meantime I'll try the update patch (thanks) and see if that doesn't solve the problem first.

Share this post

Link to post

Ok, no luck with the patch. But here's the error as taken from the dialogue box. Interestingly, this has happened with 2 different copies of the game.

--------- Game Map Shutdown ----------
ERROR: Error: file script/weapon_shotgun_double.script, line 107: Unknown value "WEAPON_NETFIRING"

Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL

Share this post

Link to post

Hrm tough one. Activision merely says the following:

Uninstall Doom 3 and the expasion, delete the game folder, and then reinstall the game and the expansion. Make sure that you do not install any third party maps/mods/skins of any type.

Yeah I know that's like their answer for everything.

Here's something that occured to me though. The weapon_netfiring variable was added in one the later patches and did not ship with the original game. Unfortunately I dont know which particular patch it came with but I assume that later patches would have added it as well.

Basically, it's an issue with your doom3 installation and not necessarily RoE.

If your're missing pak006.pk4 then that would probably explan it. Perhaps something went wrong during patching? Did you happen to do the pak file unzipping "tweak"? I think this might affect things as well.

The presence of some other pak files may be to blame as well. If you downloaded someone's mod and they happened to include their own script files they may be interfering with your own. Activisions advice on totally nuking the Doom3 directory would be a good idea in this case.

Share this post

Link to post

Ok, thanks, I'll give that a try. I know I've uninstalled and reinstalled both programs but never entirely deleted the folder manually.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this