Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Stev0

Radeon x850 xt problem

Recommended Posts

Hi, I just got a Radeon x850 xt and I'm having a problem with Doom 3. Some stuff isn't displaying right, for example, near the end of the game when your going through the dig sites, there are skeletons laying on the ground, they aren't being displayed....the intro video doesn't display the words "Doom 3" either...anyone know what's wrong ?

Share this post


Link to post

Uh, please type the rest of your CPU-specs.

I do run Doom3 with Radeon x700, and absolutely nothing wrong happens.

Share this post


Link to post

Well that's nice for you..however, mine gives me that problem and happened once I got my new card.

My specs........

Athlon 64 3200+
1 gig of RAM
Windows XP Pro (Service pack 2)
Radeon x850 xt platinum

I've put this problem on 3 different forums now and one guy's already replied saying he has the same card as me and the same problem.

Share this post


Link to post
kc32 said:

Did you update your drivers?


Yeah, I have the latest video drivers, direct X and update for Doom.

Share this post


Link to post

Come to think of it...

*checks own game for skeletons*

EDIT: What level specifically? Caverns 1? 2?

Share this post


Link to post

It's just after you kill Sarge and first go into the caverns, do you remember the bit with a computer and there's supposed to be a skeleton sitting in a chair as if he'd been killed while typing ? and there are supposed to be skeletons lying around on the ground, they aren't there, were with my old graphics card though, also the intro video doesn't display the words "Doom 3" at the beginning. I've found out a few ppl have been having the same problem. I've been trying everything I can think of really, re-installing, latest patch, latest video drivers, tried Doom without the patch too.

Share this post


Link to post

I have the same video card, and they're there on mine. Maybe special effects or something has to be on.

Share this post


Link to post

I've got all the settings on full, except Ultra mode of course. What drivers are you using ?

Share this post


Link to post

I've figured out that the stuff is actually still there..just invisible for some reason..any ideas ?

Share this post


Link to post

Sorry about posting again, I fixed it, I think it was a tweak I had, I forgot about it and since I got the new video card I dont need it anymore so I got rid of it and it all seems to be fine now. Thanks for the help.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×