Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
RTC_Marine

Bug found in 1.16 (and earlier)

Recommended Posts

to execute, do the following:

1) open doom2.wad (or any wad using doom picture format for gfx)
2) save a picture (such as CHGGA0) using Entry->Save As
3) create a new wad and try loading that picture back in, it should give you an "invalid filename"

I dont know if this happens to anyone else, but it sure is an annoying bug.

Share this post


Link to post

I did these steps and everything was fine. Doesn't seem to happen to me. Does the saved file open in other image viewers? (ie. is it a valid BMP)? After you get the error message, is it still imported?

Share this post


Link to post

I don't get that error either.

There's one thing I wanted to mention though; BMPs created that way give a kind of error message on The GIMP when opened: "Image resolution is out of bounds, using the default resolution instead." I've rarely if ever seen that except with graphics dumped by XWE. The same sprites dumped by (let's say) DeuTex won't produce the message. Other than the message I don't see any issues, though; the file doesn't seem to suffer in any obvious way.

Share this post


Link to post

Well, it's working for me, and PSP doesn't give me any indication of any kind of problem like myk mentioned with the gimp either.

Share this post


Link to post

myk, this is by design I guess. When you export sprites, XWE saves the alignment data in the BMP file. The bytes I used were zeroes in all the BMPs I ever saw, it's for image (print?) resolution according to the specs. Most programs that handle BMPs ignore these bytes, it looks like Gimp doesn't. (Unfortunately BMPs aren't extendable like GIFs or JPGs or PNGs, hence this hack.)

So basically what you gain by this is that if you export let's say 10 sprites from a WAD, and re-import them, they will retain the alignment, so you don't have to redo that manually. Try setting a sprite's alignment to 0,0 and export it: GIMP should be quiet.

If it's a real problem for you I guess I could make it optional so you'd be able to turn this behavior off.

Share this post


Link to post

Nah (as far as I'm concerned), it's just a message, and it seems handy overall. I just wondered why it came up and there is the answer.

Share this post


Link to post

I searched through the source code, but this message is not there. It probably isn't coming from XWE, but from Windows. You didn't answer my question though about the exported BMP being "fine". This may help to narrow it down: if the exported BMP is fine, then the import part is at fault. If the BMP has a problem then it's the export.

Share this post


Link to post

So it's the importing then. Does it happen for ANY bmp you try to import? (ie. something that was not exported from XWE.)

Also, during import it will try to find your DOOM.WAD. Perhaps it can't locate that file, and that's why the message comes up. Check XWE.INI, look for the (TOOLS) section at the bottom, and make sure MainWAD points to an existing (and correct) file.

Share this post


Link to post

Can't import any bitmaps? Whew, that's a pretty big bug, it renders XWE almost completely useless. I think it may be something specific to your system, something of this magnitude probably would have been noticed.

How about the MainWAD entry I asked you previously? If I assuming that setting is correct for you, I think I will have to create a special debug compile, send that to you, and ask you what it outputs. Perhaps I can track down that's causing the error. I need a bit of time for that though.

Share this post


Link to post

RTC_Marine said:
here is an example image I tried loading in but couldn't (stolen from do-tims, sorry death :P) SAU1G3

This loads into a wad for me.

Recently I've been aware of another quirk I hadn't seen before. Each time I close XWE, irrespective of whether I opened a wad with it or I simply opened the program by itself, I get the following message:



At first my IWADs were write protected (as I had copied them from a backup CD), but removing that attribute didn't get rid of the message (but maybe that has nothing to do with it...)

Share this post


Link to post

View -> Options, look what is in your temporary folder is in the general tab. Find and get the properties of the folder and uncheck "Read Only". I've only had this happen when Read Only was checked or grey-checked.

Share this post


Link to post

TheDarkArchon said:
View -> Options, look what is in your temporary folder is in the general tab. Find and get the properties of the folder and uncheck "Read Only". I've only had this happen when Read Only was checked or grey-checked.

Heh, that's it; it was set to drive C. No idea how it got that way. Thanks!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×