Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Error with 3D Mode

Recommended Posts

I've had this problem since I changed my screen resolution. I tried changing the resolution back, but it did not solve the problem.

Whenever I go into 3D mode in Doombuilder, I get this error:
"Error -2147221501 while initializing 3D mode: Direct3D could not be started."

I've tried reinstalling the latest version of DirectX, but it did not help.

If anyone can help me with my problem, it would be much appreciated.

EDIT: Switching 3D mode to run in full screen seems to have solved the problem. If I have any more issues, I'll post them here.

Share this post

Link to post

I'm having the same problem, with no solution.

"Error -2147221501 while initializing 3D mode: Direct3D could not be started."

Using version 1.68 build 385.

The problem happens regardless of configuration (window or fullscreen).

My Specs:
- NVIDIA GeForce Go 7800
- DirectX 9.0c
- Windows XP Professional SP2
- Intel P4 Centrino Dual Core
- DELL Inspiron 9400 notebook
- No other 3D apps running
- Bad mood :)

According to errlook.exe (MSVS 2005), error -2147221501 is OLE_E_ADVISENOTSUPPORTED ("This implementation doesn't take advises"). As far as I can tell, the problem occurs in "modDirectX.bas" in the "StartDirectX" proc. Unfortunately, I don't have VB 6 so I can't experiment/fix the problem myself.

This is odd though, because from what I have read, DirectX doesn't normally produce this error?

(Sorry to the non programmers who don't understand what I just said)

Has anyone else been having trouble with DB and DX9? With NVIDIA? Any ideas much appreciated!

Share this post

Link to post


On further inspection of the code, error -2147221501 has nothing to to with Direct3D: it is a custom error code (vbObjectError + 3).

The offending line is:

Set D3DD = D3D.CreateDevice(Adapter, D3DDEVTYPE_HAL, frm3D.hWnd, D3DCREATE_SOFTWARE_VERTEXPROCESSING, VideoParams)

On completion of this line, D3DD is set to Nothing, resulting in the error dialog box.

I tried updating my video drivers, and nothing has changed.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now