Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
SirBardCat

2.80GHz to 1.59GHz?

Recommended Posts

Ok, so I'm using the company's laptop, and it's clear (as shown in the device manager) that my processor is designed to run at 2.80GHz. But, look in system properties>general, you'll see it's running at only 1.59GHz. Weird.

Also, my wifes laptop has a similar issue.
She was playing some high-end game (Doom 3, or HL2, don't remember) when out of nowhere she experienced horrible fucking FPS. Looked under system properties and found that her 1.79GHz (which is compensated with a really big cache) had dropped to 787MHz. Apparently, this occurs when you unplug the adaptor, as everything starts operating at half capacity. But, this happens even when it IS plugged in, and sometimes it only goes down to 1.58GHz regardless of the adaptor being present.

I don't know what the hell either of these machines are doing, but if it helps, the first one is a Mobile Intel P4 and the second is an AMD... something. Don't have it with me at the moment.

Share this post


Link to post

It's a laptop feature, most laptops starting from late 2000 change their speed dynamically when not deployed with an adapter, to save power

Share this post


Link to post

Not a solely a bug or a feature, but a bugged feature! Those are always the best.

Share this post


Link to post

Power Options applet in Control Panel. One of the tabs should have a place to select a profile for when you're plugged in and on batteries. If you pick "maximum performance" or something like that, the processor clock speed won't be throttled down.

Share this post


Link to post
Bloodshedder said:

throttled down.


"Throttling you down? That's not one of the 99 ways I rip you off."

Ok, I'll stop. However, it does seem weird that it does happen even with the supply plugged in: I have my supply plugged in most of the time I'm on my laptop (Which is a lot) and I never get said CPU drop.I notice it when I'm unplugged, though. However, I tend not to play games on the move (which is when it's noticible) very often due to a lack of a usable mouse surface. My mouse works on practically anywhere since it's an optical one but most places I use my laptop on the move doesn't allow for great freedom either so moving it can be a pain in the arse. Using a touchpad for games just plain sucks.

Share this post


Link to post
Bloodshedder said:

Power Options applet in Control Panel. One of the tabs should have a place to select a profile for when you're plugged in and on batteries. If you pick "maximum performance" or something like that, the processor clock speed won't be throttled down.


Worked perfectly.

Tried that before, but didn't see anything about CPU performance, so I disregarded it as a solution to the problem. Anyways, problem solved. Thanks. :)

Now to see if it works on the other notebook.

Share this post


Link to post

You know, when your 3GHz computer is idling at 1% CPU usage then it's essentially running at 30MHz. So who cares if it throttles down to save power?

I suppose you'd feel better if your computer always ran at 100% CPU usage and consumed all that extra power as a result. I think there may be some spyware out there that can help you achieve that.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×