Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

flats gaining corrupt pixels when importing

Recommended Posts

tried latest beta, getting same problem, seems to be since 116? as havent had this problem on my pc at home and that one is an OLLLD version

1. laod wad (a doom2 game wad)
2. go to flats (floors) tab
3. click on an entry
4. menu->entry->replace
5. select bmp file (let xwe do the pallette)
6. some bizzare thing happens where theres a blank screen but with offset crosshairs
7. click on an other entry
8. a prompt comes up asking you if you want to save changes to the entry you were just on, click yes

this seems to replace the entry, but when i click back on the entry and/or view in doombuilder/winmbf you can see that a few pixels to the top left of the flat are corrupt. is it extra data being overwritten on top of the bmp data perhaps?

suppose i could try deleting the existing entry, loading a new one and then renaming it to the same name as the old one, hang on...

edit: yeah that worked, but it prompts me to save changes to a flat even if i didnt change it and just happened to be clicked on it whilst doing sometihng else. (i.e. select a flat, then click menu->entry->load to load a new entry, when you've done it asks you if you want to save changes to the original flat)

Share this post

Link to post

I carefully followed your steps, but I could not reproduce this bug. When I replaced any flat with a BMP, it was fine on the first try. (Even when the BMP was not a valid 64x64 image.)

Could this have been the particular BMP you were trying to import? If you can still reproduce it, please send me your WAD and your BMP file.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this