Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Steps for Texture Editing ....

Recommended Posts

Csabo, someone had a question on inserting textures into a wad in a manner that would not replace existing textures. I have listed the steps using XWE in this thread. Please review the steps and let me know if I did not get anything right. If it's good I'd like to put this up on my site as one of my many tutorials for newbies.

Also, I vaguely remember having a discussion with you when you were first developing XWE, where you were surprised that there was no provision to automatically insert TEXTURE and PNAMES lumps into a wad. [The way I currently do it is to open doom.wad or doom2.wad and save the lumps, then load those lumps into my PWAD.] I could not find an easier way to insert these lumps. Let me know if I'm not looking in the right place.

Share this post

Link to post

Hey ReX,

From the thread it looks like the original question is just regarding importing new textures. If that's all you need to do, it can be done in a lot less steps. Just one, really: double-click the PATCHES button from the Filter toolbar. This will let you import all your textures (as long as they are in one folder), it creates the PP_START/PP_END entries, adds them to the PNAMES and TEXTURE1 lumps (grabs those from the main WAD if they are not yet present).

I revamped the XWE's help file a while back, it's much better than it used to be (I hope). In the "Documentation" section I tried to cover basics of WAD editing. I'd like add more though, so if you (or anyone else) comes up with tutorials, I'd be happy to add it.

Share this post

Link to post

Csabo, I tried what you suggested (I'm still using v1.15) and got this error message:

Access violation at address 00403E20 in module 'XWE.EXE'. Write of address 00000024.

It imported the last graphic from the list I had selected in my textures folder, and inserted a TEXTURE1 and a PNAMES entry. However, neither of these entries included the patch that had been imported.

Then I repeated the double-click maneuver and selected all but the last of the graphics (which had already been imported in the first try). This time it imported all of the graphics just fine, and the TEXTURE1 and PNAMES entry included all the graphics. [The first one that had been imported during the first try was still missing.]

Tomorrow I will download v1.16 and try this thing again.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this