Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
eltro

Monsters shoot through walls

Recommended Posts

When editing doom, monsters can shoot through walls, but not obstacles, and i dont know how to stop this. Can anybody help?

Share this post


Link to post

Try using stronger wall textures (i.e. instead of wood textures use metal, instead of human bricks use hell bricks, or solid rocks, and so on). Just kidding, I had the same problem years ago (and stupidly enough I tried what I said). The problem is because your walls are two sided, if you want to save the maps you have made, be sure to remove the second side (add -1 in sector reference at the second sidef), for new maps when you add a new sector, it all depends what editor you're using, the olders require you to press "ins" the newer turn the lines two sided if you press it.
But probably the reason is because you need a node builder, try idbsp or some of these that are linked in the "utilities" section at the main page.
I hope it helps, yet I know that some times I'm not that clear as I'd like to be, so feel free to keep asking.

For more specific questions perhaps you'd like to upload the wad and post the link here.

Share this post


Link to post

If you are using Zdoom format, set the flag on BLOCK everything. And also, monsters CANT shoot rhough a real WALL. I think you're refering the the double sided textures that has only impassible set.

Share this post


Link to post

Ah, the problem of the " Monster shoots through wall " kind of deal, what you do really is make the wall impassable or add something like that, and one thing though, if it's a wall not connected to other part of a wall like this


__________________

I
I
I


__________________

But not a pillar or step, then it's a pass by, but needs Impassable on inorder to block, but it sometimes if checking for errors, that it's a unclosed sector, then you may have to do some adjusting.

Share this post


Link to post

There's another way to deal with this problem, especially if a double-sided wall is needed. Simple by reducing your grid down to "2" and installing a "void" wall just outside of the double-sided wall the monsters are shooting through. The space, "void"... is a small area that carries NO sector attributes. I ran into this problem when I was trying to build an "outside" sector to my map and when I walked around outside, the monsters shot at me through the walls. I installed the "void" area and had no more problems!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×