Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
prewitt86

3D Doom

Recommended Posts

Very old versions of EDGE used to, the ones that crashed every 5 minutes and didnt let you save. If you must try it...

Share this post


Link to post

I'd love to play DOOM with a virtual reality helmet. That'd hurt eyes so badly, but the irreversible damage to the vision sense would be compensated with the experience.

Share this post


Link to post
deathbringer said:

Very old versions of EDGE used to, the ones that crashed every 5 minutes and didnt let you save. If you must try it...


That version worked better for me than the latest I tried, that one hard crashed my computer all the time.

Share this post


Link to post
Vegeta said:

I'd love to play DOOM with a virtual reality helmet. That'd hurt eyes so badly, but the irreversible damage to the vision sense would be compensated with the experience.

When Heretic was new, I saw a store display that had it hooked up to a VR helmet. I got to try it for a few minutes, it was nice but the helmet sensed vertical movement and was linked to the game's look up/down control, which wasn't a bad idea in theory but it was sensitive enough that I'd lose my place in the game every time I sneezed or coughed.

Share this post


Link to post

I've played Descent with a VR helmet. It was pretty neat, but you had to take off the thing after every level or risk having your eyes explode (that's what it felt like, at least).

I remember an old issue of PC Gamer where they reviewed VR helmets support with the games of the day. Doom didn't fare so well, but as I recall Dark Forces was said to be a cool experience. I don't remember if it was just due to being able to look up and down.

Share this post


Link to post

Geez, I wouldn't bother with that. Personally, I think the 3D models for Jdoom look sufficient :-p

Share this post


Link to post
kristus said:

That version worked better for me than the latest I tried, that one hard crashed my computer all the time.


I heard this happened to some people with RC3 (the one with multiple .exes in the zip). Did you try with RC4, installing on top of RC3? That seems to fix it for most people.

If not we'd be happy to get some debuggin info from you.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×