Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Mr_Myaghi

Doom for Linux help!

Recommended Posts

I first downloaded a doom version from cnet but couldn't get it to work, so I downloaded another version. I am 100% sure I have all the needed libraries needed. I've tested both with the rpms from mandrake and from the game website...doesn't do any difference. If you have any idea, please help me out. I'm trying to compile but in the ./configure script I get following error:

checking for x... no
checking for sdl-config... no
checking for SDL - version >= 1.1.3... no
*** The sdl-config script installed by SDL could not be found
*** If SDL was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the SDL_CONFIG envionment variable to the
*** full path to sdl-config.
checking for SMPEG_playAudio in -lsmpeg... no
checking fo Mix_loadMUS in -lSDL_mixer... no
*** Compiling without SDL_mixer installed probably won't work
checking for SDLNet_UDP_Bind in -lSDL_net... no
configure: error: *** You must have the SDL libraries installed before y
*** See http://prboom.sourceforge.net/linux.html

Share this post


Link to post

You need to install LibSDL, like it says. You also need the SDL_mixer and SDL_net libraries to compile it. You can get these from http://www.libsdl.org/ if the packages on the PrBoom website wont work.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
×